lua-Harness

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

lua-Harness

Dibyendu Majumdar
@François Perrad

Hi,

I noticed that Ravi support has been added?
Thank you for that - interested to know any feedback.

Regards
Dibyendu

Reply | Threaded
Open this post in threaded view
|

Re: lua-Harness

François Perrad


Le ven. 17 janv. 2020 à 14:36, Dibyendu Majumdar <[hidden email]> a écrit :
@François Perrad

Hi,

I noticed that Ravi support has been added?
Thank you for that - interested to know any feedback.


Hi Dibyendu,

The support of Ravi in lua-Harness has required little effort.

Currently with Ravi, _VERSION = 'Ravi 5.3'
In order to have a better compatibility with existing Lua code & libraries,
I think it is better to have :
_VERSION = 'Lua 5.3'   (as Ravi is aligned with Lua 5.3)
ravi.version = 'Ravi 1.0-beta3' (like jit.version in LuaJIT)

Regards

François

 
Regards
Dibyendu

Reply | Threaded
Open this post in threaded view
|

Re: lua-Harness

Dibyendu Majumdar
Hi François,

On Sat, 18 Jan 2020 at 09:43, François Perrad <[hidden email]> wrote:

> The support of Ravi in lua-Harness has required little effort.
>

That's good to know.

> Currently with Ravi, _VERSION = 'Ravi 5.3'
> In order to have a better compatibility with existing Lua code & libraries,
> I think it is better to have :
> _VERSION = 'Lua 5.3'   (as Ravi is aligned with Lua 5.3)
> ravi.version = 'Ravi 1.0-beta3' (like jit.version in LuaJIT)
>

Okay thank you - I will implement the suggestion in the near future.

Regards
Dibyendu