Unable to download patches from http://lua-users.org/wiki/LuaPowerPatches

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to download patches from http://lua-users.org/wiki/LuaPowerPatches

BogdanM
Hi,

I'm trying to download some patches for Lua 5.3 from http://lua-users.org/wiki/LuaPowerPatches, but it seems that the ones hosted on lua-users.org can't be dowloaded (404 errors). Some examples (there are more):

http://lua-users.org/files/wiki_insecure/power_patches/5.3/lua-5.3.4-named-library.patch from "Preload libraries with customized global names (5.3.4)"

Is this a known issue?

Thanks,
Bogdan

Reply | Threaded
Open this post in threaded view
|

Re: Unable to download patches from http://lua-users.org/wiki/LuaPowerPatches

Ką Mykolas
mhm. The whole directory seems to be missing: http://lua-users.org/files/wiki_insecure/power_patches

On Wed, May 8, 2019 at 3:55 PM Bogdan Marinescu <[hidden email]> wrote:
Hi,

I'm trying to download some patches for Lua 5.3 from http://lua-users.org/wiki/LuaPowerPatches, but it seems that the ones hosted on lua-users.org can't be dowloaded (404 errors). Some examples (there are more):

http://lua-users.org/files/wiki_insecure/power_patches/5.3/lua-5.3.4-named-library.patch from "Preload libraries with customized global names (5.3.4)"

Is this a known issue?

Thanks,
Bogdan

Reply | Threaded
Open this post in threaded view
|

Re: Unable to download patches from http://lua-users.org/wiki/LuaPowerPatches

Ką Mykolas
For quick reference, it's still available on WebArchives: https://web.archive.org/web/20160712114727/http://lua-users.org/wiki/LuaPowerPatches

On Wed, May 8, 2019 at 4:15 PM Ką Mykolas <[hidden email]> wrote:
mhm. The whole directory seems to be missing: http://lua-users.org/files/wiki_insecure/power_patches

On Wed, May 8, 2019 at 3:55 PM Bogdan Marinescu <[hidden email]> wrote:
Hi,

I'm trying to download some patches for Lua 5.3 from http://lua-users.org/wiki/LuaPowerPatches, but it seems that the ones hosted on lua-users.org can't be dowloaded (404 errors). Some examples (there are more):

http://lua-users.org/files/wiki_insecure/power_patches/5.3/lua-5.3.4-named-library.patch from "Preload libraries with customized global names (5.3.4)"

Is this a known issue?

Thanks,
Bogdan

Reply | Threaded
Open this post in threaded view
|

Re: Unable to download patches from http://lua-users.org/wiki/LuaPowerPatches

BogdanM

On Wed, May 8, 2019 at 4:18 PM Ką Mykolas <[hidden email]> wrote:
For quick reference, it's still available on WebArchives: https://web.archive.org/web/20160712114727/http://lua-users.org/wiki/LuaPowerPatches

On Wed, May 8, 2019 at 4:15 PM Ką Mykolas <[hidden email]> wrote:
mhm. The whole directory seems to be missing: http://lua-users.org/files/wiki_insecure/power_patches

On Wed, May 8, 2019 at 3:55 PM Bogdan Marinescu <[hidden email]> wrote:
Hi,

I'm trying to download some patches for Lua 5.3 from http://lua-users.org/wiki/LuaPowerPatches, but it seems that the ones hosted on lua-users.org can't be dowloaded (404 errors). Some examples (there are more):

http://lua-users.org/files/wiki_insecure/power_patches/5.3/lua-5.3.4-named-library.patch from "Preload libraries with customized global names (5.3.4)"

Is this a known issue?

Thanks,
Bogdan

Reply | Threaded
Open this post in threaded view
|

Re: Unable to download patches from http://lua-users.org/wiki/LuaPowerPatches

BogdanM
Any news on this? Am I to understand that those patches are lost forever? Surely that can't be right.

On Wed, May 8, 2019 at 4:30 PM Bogdan Marinescu <[hidden email]> wrote:

On Wed, May 8, 2019 at 4:18 PM Ką Mykolas <[hidden email]> wrote:
For quick reference, it's still available on WebArchives: https://web.archive.org/web/20160712114727/http://lua-users.org/wiki/LuaPowerPatches

On Wed, May 8, 2019 at 4:15 PM Ką Mykolas <[hidden email]> wrote:
mhm. The whole directory seems to be missing: http://lua-users.org/files/wiki_insecure/power_patches

On Wed, May 8, 2019 at 3:55 PM Bogdan Marinescu <[hidden email]> wrote:
Hi,

I'm trying to download some patches for Lua 5.3 from http://lua-users.org/wiki/LuaPowerPatches, but it seems that the ones hosted on lua-users.org can't be dowloaded (404 errors). Some examples (there are more):

http://lua-users.org/files/wiki_insecure/power_patches/5.3/lua-5.3.4-named-library.patch from "Preload libraries with customized global names (5.3.4)"

Is this a known issue?

Thanks,
Bogdan

Reply | Threaded
Open this post in threaded view
|

Re: Unable to download patches from http://lua-users.org/wiki/LuaPowerPatches

Gabriel Bertilson
If you are interested in particular ones, here are the "advanced
readline" and "named library" patches for Lua 5.3.1 and Lua 5.3.4
respectively, originally downloaded from the lua-users wiki.

— Gabriel

— Gabriel



On Mon, May 13, 2019 at 6:50 AM Bogdan Marinescu
<[hidden email]> wrote:

>
> Any news on this? Am I to understand that those patches are lost forever? Surely that can't be right.
>
> On Wed, May 8, 2019 at 4:30 PM Bogdan Marinescu <[hidden email]> wrote:
>>
>> Thanks, but unfortunately that doesn't work either: https://web.archive.org/web/*/http://lua-users.org/files/wiki_insecure/power_patches/5.3/*
>>
>> On Wed, May 8, 2019 at 4:18 PM Ką Mykolas <[hidden email]> wrote:
>>>
>>> For quick reference, it's still available on WebArchives: https://web.archive.org/web/20160712114727/http://lua-users.org/wiki/LuaPowerPatches
>>>
>>> On Wed, May 8, 2019 at 4:15 PM Ką Mykolas <[hidden email]> wrote:
>>>>
>>>> mhm. The whole directory seems to be missing: http://lua-users.org/files/wiki_insecure/power_patches
>>>>
>>>> On Wed, May 8, 2019 at 3:55 PM Bogdan Marinescu <[hidden email]> wrote:
>>>>>
>>>>> Hi,
>>>>>
>>>>> I'm trying to download some patches for Lua 5.3 from http://lua-users.org/wiki/LuaPowerPatches, but it seems that the ones hosted on lua-users.org can't be dowloaded (404 errors). Some examples (there are more):
>>>>>
>>>>> - http://lua-users.org/files/wiki_insecure/power_patches/5.3/lua-5.3.4-named-library.patch from "Preload libraries with customized global names (5.3.4)"
>>>>> - http://lua-users.org/files/wiki_insecure/power_patches/5.3/NoFlua-5.3.3.patch from "No Floating-Point Option (5.3)"
>>>>>
>>>>> Is this a known issue?
>>>>>
>>>>> Thanks,
>>>>> Bogdan
>>>>>

lua-5.3.1-advanced_readline.patch (12K) Download Attachment
lua-5.3.4-named-library.patch (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Unable to download patches from http://lua-users.org/wiki/LuaPowerPatches

BogdanM
Hi Gabriel,

On Mon, May 13, 2019 at 7:59 PM Gabriel Bertilson <[hidden email]> wrote:
If you are interested in particular ones, here are the "advanced
readline" and "named library" patches for Lua 5.3.1 and Lua 5.3.4
respectively, originally downloaded from the lua-users wiki.

Thanks a lot for your help. I'm particularly interested in the No Floating-Point Option patch for Lua 5.3 (5.3.3 fi possible, but the earlier ones would work too).

Thanks,
Bogdan
 

— Gabriel

— Gabriel



On Mon, May 13, 2019 at 6:50 AM Bogdan Marinescu
<[hidden email]> wrote:
>
> Any news on this? Am I to understand that those patches are lost forever? Surely that can't be right.
>
> On Wed, May 8, 2019 at 4:30 PM Bogdan Marinescu <[hidden email]> wrote:
>>
>> Thanks, but unfortunately that doesn't work either: https://web.archive.org/web/*/http://lua-users.org/files/wiki_insecure/power_patches/5.3/*
>>
>> On Wed, May 8, 2019 at 4:18 PM Ką Mykolas <[hidden email]> wrote:
>>>
>>> For quick reference, it's still available on WebArchives: https://web.archive.org/web/20160712114727/http://lua-users.org/wiki/LuaPowerPatches
>>>
>>> On Wed, May 8, 2019 at 4:15 PM Ką Mykolas <[hidden email]> wrote:
>>>>
>>>> mhm. The whole directory seems to be missing: http://lua-users.org/files/wiki_insecure/power_patches
>>>>
>>>> On Wed, May 8, 2019 at 3:55 PM Bogdan Marinescu <[hidden email]> wrote:
>>>>>
>>>>> Hi,
>>>>>
>>>>> I'm trying to download some patches for Lua 5.3 from http://lua-users.org/wiki/LuaPowerPatches, but it seems that the ones hosted on lua-users.org can't be dowloaded (404 errors). Some examples (there are more):
>>>>>
>>>>> - http://lua-users.org/files/wiki_insecure/power_patches/5.3/lua-5.3.4-named-library.patch from "Preload libraries with customized global names (5.3.4)"
>>>>> - http://lua-users.org/files/wiki_insecure/power_patches/5.3/NoFlua-5.3.3.patch from "No Floating-Point Option (5.3)"
>>>>>
>>>>> Is this a known issue?
>>>>>
>>>>> Thanks,
>>>>> Bogdan
>>>>>
Reply | Threaded
Open this post in threaded view
|

Re: Unable to download patches from http://lua-users.org/wiki/LuaPowerPatches

Gabriel Bertilson
Unfortunately, these were the only two patches that I downloaded.

— Gabriel

On Mon, May 13, 2019 at 1:26 PM Bogdan Marinescu
<[hidden email]> wrote:

>
> Hi Gabriel,
>
> On Mon, May 13, 2019 at 7:59 PM Gabriel Bertilson <[hidden email]> wrote:
>>
>> If you are interested in particular ones, here are the "advanced
>> readline" and "named library" patches for Lua 5.3.1 and Lua 5.3.4
>> respectively, originally downloaded from the lua-users wiki.
>
>
> Thanks a lot for your help. I'm particularly interested in the No Floating-Point Option patch for Lua 5.3 (5.3.3 fi possible, but the earlier ones would work too).
>
> Thanks,
> Bogdan
>
>>
>>
>> — Gabriel
>>
>> — Gabriel
>>
>>
>>
>> On Mon, May 13, 2019 at 6:50 AM Bogdan Marinescu
>> <[hidden email]> wrote:
>> >
>> > Any news on this? Am I to understand that those patches are lost forever? Surely that can't be right.
>> >
>> > On Wed, May 8, 2019 at 4:30 PM Bogdan Marinescu <[hidden email]> wrote:
>> >>
>> >> Thanks, but unfortunately that doesn't work either: https://web.archive.org/web/*/http://lua-users.org/files/wiki_insecure/power_patches/5.3/*
>> >>
>> >> On Wed, May 8, 2019 at 4:18 PM Ką Mykolas <[hidden email]> wrote:
>> >>>
>> >>> For quick reference, it's still available on WebArchives: https://web.archive.org/web/20160712114727/http://lua-users.org/wiki/LuaPowerPatches
>> >>>
>> >>> On Wed, May 8, 2019 at 4:15 PM Ką Mykolas <[hidden email]> wrote:
>> >>>>
>> >>>> mhm. The whole directory seems to be missing: http://lua-users.org/files/wiki_insecure/power_patches
>> >>>>
>> >>>> On Wed, May 8, 2019 at 3:55 PM Bogdan Marinescu <[hidden email]> wrote:
>> >>>>>
>> >>>>> Hi,
>> >>>>>
>> >>>>> I'm trying to download some patches for Lua 5.3 from http://lua-users.org/wiki/LuaPowerPatches, but it seems that the ones hosted on lua-users.org can't be dowloaded (404 errors). Some examples (there are more):
>> >>>>>
>> >>>>> - http://lua-users.org/files/wiki_insecure/power_patches/5.3/lua-5.3.4-named-library.patch from "Preload libraries with customized global names (5.3.4)"
>> >>>>> - http://lua-users.org/files/wiki_insecure/power_patches/5.3/NoFlua-5.3.3.patch from "No Floating-Point Option (5.3)"
>> >>>>>
>> >>>>> Is this a known issue?
>> >>>>>
>> >>>>> Thanks,
>> >>>>> Bogdan
>> >>>>>

Reply | Threaded
Open this post in threaded view
|

Re: Unable to download patches from http://lua-users.org/wiki/LuaPowerPatches

John Belmonte
In reply to this post by BogdanM
I'll restore the files from backup in the next 24 hours and report back.

On Mon, May 13, 2019, 8:50 PM Bogdan Marinescu <[hidden email]> wrote:
Any news on this? Am I to understand that those patches are lost forever? Surely that can't be right.

On Wed, May 8, 2019 at 4:30 PM Bogdan Marinescu <[hidden email]> wrote:

On Wed, May 8, 2019 at 4:18 PM Ką Mykolas <[hidden email]> wrote:
For quick reference, it's still available on WebArchives: https://web.archive.org/web/20160712114727/http://lua-users.org/wiki/LuaPowerPatches

On Wed, May 8, 2019 at 4:15 PM Ką Mykolas <[hidden email]> wrote:
mhm. The whole directory seems to be missing: http://lua-users.org/files/wiki_insecure/power_patches

On Wed, May 8, 2019 at 3:55 PM Bogdan Marinescu <[hidden email]> wrote:
Hi,

I'm trying to download some patches for Lua 5.3 from http://lua-users.org/wiki/LuaPowerPatches, but it seems that the ones hosted on lua-users.org can't be dowloaded (404 errors). Some examples (there are more):

http://lua-users.org/files/wiki_insecure/power_patches/5.3/lua-5.3.4-named-library.patch from "Preload libraries with customized global names (5.3.4)"

Is this a known issue?

Thanks,
Bogdan

Reply | Threaded
Open this post in threaded view
|

Re: Unable to download patches from http://lua-users.org/wiki/LuaPowerPatches

John Belmonte
I've restored the files.

The deletion took place between 2018-Dec-1 and 2019-Feb-3.

Regards,
--John


On Tue, May 14, 2019 at 7:59 AM John Belmonte <[hidden email]> wrote:
I'll restore the files from backup in the next 24 hours and report back.

On Mon, May 13, 2019, 8:50 PM Bogdan Marinescu <[hidden email]> wrote:
Any news on this? Am I to understand that those patches are lost forever? Surely that can't be right.

On Wed, May 8, 2019 at 4:30 PM Bogdan Marinescu <[hidden email]> wrote:

On Wed, May 8, 2019 at 4:18 PM Ką Mykolas <[hidden email]> wrote:
For quick reference, it's still available on WebArchives: https://web.archive.org/web/20160712114727/http://lua-users.org/wiki/LuaPowerPatches

On Wed, May 8, 2019 at 4:15 PM Ką Mykolas <[hidden email]> wrote:
mhm. The whole directory seems to be missing: http://lua-users.org/files/wiki_insecure/power_patches

On Wed, May 8, 2019 at 3:55 PM Bogdan Marinescu <[hidden email]> wrote:
Hi,

I'm trying to download some patches for Lua 5.3 from http://lua-users.org/wiki/LuaPowerPatches, but it seems that the ones hosted on lua-users.org can't be dowloaded (404 errors). Some examples (there are more):

http://lua-users.org/files/wiki_insecure/power_patches/5.3/lua-5.3.4-named-library.patch from "Preload libraries with customized global names (5.3.4)"

Is this a known issue?

Thanks,
Bogdan

Reply | Threaded
Open this post in threaded view
|

Re: Unable to download patches from http://lua-users.org/wiki/LuaPowerPatches

BogdanM
Many thanks for your help!

Best,
Bogdan

On Tue, May 14, 2019 at 2:34 PM John Belmonte <[hidden email]> wrote:
I've restored the files.

The deletion took place between 2018-Dec-1 and 2019-Feb-3.

Regards,
--John


On Tue, May 14, 2019 at 7:59 AM John Belmonte <[hidden email]> wrote:
I'll restore the files from backup in the next 24 hours and report back.

On Mon, May 13, 2019, 8:50 PM Bogdan Marinescu <[hidden email]> wrote:
Any news on this? Am I to understand that those patches are lost forever? Surely that can't be right.

On Wed, May 8, 2019 at 4:30 PM Bogdan Marinescu <[hidden email]> wrote:

On Wed, May 8, 2019 at 4:18 PM Ką Mykolas <[hidden email]> wrote:
For quick reference, it's still available on WebArchives: https://web.archive.org/web/20160712114727/http://lua-users.org/wiki/LuaPowerPatches

On Wed, May 8, 2019 at 4:15 PM Ką Mykolas <[hidden email]> wrote:
mhm. The whole directory seems to be missing: http://lua-users.org/files/wiki_insecure/power_patches

On Wed, May 8, 2019 at 3:55 PM Bogdan Marinescu <[hidden email]> wrote:
Hi,

I'm trying to download some patches for Lua 5.3 from http://lua-users.org/wiki/LuaPowerPatches, but it seems that the ones hosted on lua-users.org can't be dowloaded (404 errors). Some examples (there are more):

http://lua-users.org/files/wiki_insecure/power_patches/5.3/lua-5.3.4-named-library.patch from "Preload libraries with customized global names (5.3.4)"

Is this a known issue?

Thanks,
Bogdan