Some more problems, IUP this time. Was: Problem compiling CD on OS X

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Some more problems, IUP this time. Was: Problem compiling CD on OS X

Roman Maire
Hello
 
Now that CD compiles, I'm fiddling with IUP. If I try to make from the iup directory, I get the following error message:
 

Tecmake: linking libiupluagl51.so ...

gcc -bundle -undefined dynamic_lookup -o ../lib/MacOS106/libiupluagl51.so ../obj/iupluagl51/MacOS106/iuplua_glcanvas.o ../obj/iupluagl51/MacOS106/il_glcanvas.o  -L../lib/MacOS106 -liupgl -liup -lGLU -lGL -lm

ld: library not found for -lGLU

collect2: ld returned 1 exit status

make[2]: *** [../lib/MacOS106/libiupluagl51.so] Error 1

make[1]: *** [iupluagl] Error 2

make: *** [iuplua5] Error 2
 
It seems that the flag -framework OpenGL is missing. Adding it in the toplevel tecmake.mak didn't work.
 
Out of curiosity I was then trying to uncomment the target for iupluagl in the Makefile in iup/srclua5. I got the following error message:
 

Tecmake: linking libiupluaim51.so ...

gcc -bundle -undefined dynamic_lookup -o ../lib/MacOS106/libiupluaim51.so ../obj/iupluaim51/MacOS106/iuplua_im.o  -L../lib/MacOS106 -L../lib/MacOS106 -L../../im/lib/MacOS106 -liupim -limlua51 -liup -lim -lm

ld: in ../../im/lib/MacOS106/libimlua51.so, can't link with bundle (MH_BUNDLE) only dylibs (MH_DYLIB)

collect2: ld returned 1 exit status

make[2]: *** [../lib/MacOS106/libiupluaim51.so] Error 1

make[1]: *** [iupluaim] Error 2

make: *** [iuplua5] Error 2
 
 
Some ideas?
 
Kind regards,
 
Roman Maire

Reply | Threaded
Open this post in threaded view
|

RE: Some more problems, IUP this time. Was: Problem compiling CD on OS X

Antonio Scuri

Hi,

 

  Second problem, change the last part of the “iup/srclua5/iupim.mak” to:

 

ifneq ($(findstring MacOS, $(TEC_UNAME)), )

  USE_IUPLUA:=

  USE_IMLUA:=

  USE_IM = Yes

endif

 

   First problem, change the last part of the “iup/srclua5/iupim.mak” to:

 

ifneq ($(findstring MacOS, $(TEC_UNAME)), )

  LIBS:=

  ifdef USE_MACOS_OPENGL

    LFLAGS = -framework OpenGL

    USE_OPENGL :=

  endif

endif

 

   And define USE_MACOS_OPENGL on your environment before compiling the code.

 

   These changes are done in the CVS version of IUP, CD and IM.

 

Best,

Scuri

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of [hidden email]
Sent: segunda-feira, 14 de novembro de 2011 12:28
To: [hidden email]
Subject: Some more problems, IUP this time. Was: Problem compiling CD on OS X

 

Hello
 
Now that CD compiles, I'm fiddling with IUP. If I try to make from the iup directory, I get the following error message:
 

Tecmake: linking libiupluagl51.so ...

gcc -bundle -undefined dynamic_lookup -o ../lib/MacOS106/libiupluagl51.so ../obj/iupluagl51/MacOS106/iuplua_glcanvas.o ../obj/iupluagl51/MacOS106/il_glcanvas.o  -L../lib/MacOS106 -liupgl -liup -lGLU -lGL -lm

ld: library not found for -lGLU

collect2: ld returned 1 exit status

make[2]: *** [../lib/MacOS106/libiupluagl51.so] Error 1

make[1]: *** [iupluagl] Error 2

make: *** [iuplua5] Error 2
 
It seems that the flag -framework OpenGL is missing. Adding it in the toplevel tecmake.mak didn't work.
 
Out of curiosity I was then trying to uncomment the target for iupluagl in the Makefile in iup/srclua5. I got the following error message:
 

Tecmake: linking libiupluaim51.so ...

gcc -bundle -undefined dynamic_lookup -o ../lib/MacOS106/libiupluaim51.so ../obj/iupluaim51/MacOS106/iuplua_im.o  -L../lib/MacOS106 -L../lib/MacOS106 -L../../im/lib/MacOS106 -liupim -limlua51 -liup -lim -lm

ld: in ../../im/lib/MacOS106/libimlua51.so, can't link with bundle (MH_BUNDLE) only dylibs (MH_DYLIB)

collect2: ld returned 1 exit status

make[2]: *** [../lib/MacOS106/libiupluaim51.so] Error 1

make[1]: *** [iupluaim] Error 2

make: *** [iuplua5] Error 2
 
 
Some ideas?
 
Kind regards,
 
Roman Maire

Reply | Threaded
Open this post in threaded view
|

Re: Some more problems, IUP this time. Was: Problem compiling CD on OS X

Roman Maire
Yay, It compiles! I've got the parts I need to start my project, thank
you. Some more comments:

- I had to comment out iupconsole in the toplevel makefile, else it
would give the following error:

Tecmake: linking iuplua51 ...
g++ -o ../bin/MacOS106/iuplua51 ../obj/iuplua51/MacOS106/iup_lua51.o
-L../../lua5.1/lib/MacOS106 -lreadline -llua5.1 -lm
ld: in ../../lua5.1/lib/MacOS106/liblua5.1.so, can't link with bundle
(MH_BUNDLE) only dylibs (MH_DYLIB)
collect2: ld returned 1 exit status
make[2]: *** [../bin/MacOS106/iuplua51] Error 1
make[1]: *** [iuplua5] Error 2
make: *** [iupconsole] Error 2

- The sample files colorbrowser.wlua, dial.wlua, gauge.wlua,
lfs_tree.wlua, getparam.wlua, mask.wlua, mask_matrix.wlua, matrix.wlua,
matrix_cbmode.wlua, pplot_bar.wlua, sbox.wlua, tabs.wlua, tree1.wlua and
val.wlua give the following error:

lua: error loading module 'iupluacontrols' from file
'/usr/local/lib/lua/5.1/libiupluacontrols51.so':
        dlopen(/usr/local/lib/lua/5.1/libiupluacontrols51.so, 2): Symbol not
found: _cdlua_pushcanvas
  Referenced from: /usr/local/lib/lua/5.1/libiupluacontrols51.so
  Expected in: flat namespace
 in /usr/local/lib/lua/5.1/libiupluacontrols51.so
stack traceback:
        [C]: ?
        [C]: in function 'require'
        dial.wlua:4: in main chunk
        [C]: ?

- The sample files glcanvas.wlua and luagl.wlua give the following error:

lua: error loading module 'iupluagl' from file
'/usr/local/lib/lua/5.1/libiupluagl51.so':
        dlopen(/usr/local/lib/lua/5.1/libiupluagl51.so, 2): Symbol not found:
_IupGLCanvas
  Referenced from: /usr/local/lib/lua/5.1/libiupluagl51.so
  Expected in: flat namespace
 in /usr/local/lib/lua/5.1/libiupluagl51.so
stack traceback:
        [C]: ?
        [C]: in function 'require'
        glcanvas.wlua:6: in main chunk
        [C]: ?

- The example file pplot.wlua gives me the following error:

lua: pplot.wlua:1: attempt to index global 'iup' (a nil value)
stack traceback:
        pplot.wlua:1: in main chunk
        [C]: ?

- The example file image.wlua stops with the following message: Abort trap

I've built all three libraries from their CVS versions, Lua is still the
source distribution from luabinaries. I can run some more tests if this
would be of any help.

Kind regards,

Roman Maire

Am 16.11.2011 19:15, schrieb Antonio Scuri:

> Hi,
>
>  
>
>   Second problem, change the last part of the “iup/srclua5/iupim.mak” to:
>
>  
>
> ifneq ($(findstring MacOS, $(TEC_UNAME)), )
>
>   USE_IUPLUA:=
>
>   USE_IMLUA:=
>
>   USE_IM = Yes
>
> endif
>
>  
>
>    First problem, change the last part of the “iup/srclua5/iupim.mak” to:
>
>  
>
> ifneq ($(findstring MacOS, $(TEC_UNAME)), )
>
>   LIBS:=
>
>   ifdef USE_MACOS_OPENGL
>
>     LFLAGS = -framework OpenGL
>
>     USE_OPENGL :=
>
>   endif
>
> endif
>
>  
>
>    And define USE_MACOS_OPENGL on your environment before compiling the
> code.
>
>  
>
>    These changes are done in the CVS version of IUP, CD and IM.
>
>  
>
> Best,
>
> Scuri
>
>  
>
> *From:*[hidden email] [mailto:[hidden email]]
> *On Behalf Of *[hidden email]
> *Sent:* segunda-feira, 14 de novembro de 2011 12:28
> *To:* [hidden email]
> *Subject:* Some more problems, IUP this time. Was: Problem compiling CD
> on OS X
>
>  
>
> Hello
>  
> Now that CD compiles, I'm fiddling with IUP. If I try to make from the
> iup directory, I get the following error message:
>  
>
> Tecmake: linking libiupluagl51.so ...
>
> gcc -bundle -undefined dynamic_lookup -o
> ../lib/MacOS106/libiupluagl51.so
> ../obj/iupluagl51/MacOS106/iuplua_glcanvas.o
> ../obj/iupluagl51/MacOS106/il_glcanvas.o  -L../lib/MacOS106 -liupgl
> -liup -lGLU -lGL -lm
>
> ld: library not found for -lGLU
>
> collect2: ld returned 1 exit status
>
> make[2]: *** [../lib/MacOS106/libiupluagl51.so] Error 1
>
> make[1]: *** [iupluagl] Error 2
>
> make: *** [iuplua5] Error 2
>  
> It seems that the flag -framework OpenGL is missing. Adding it in the
> toplevel tecmake.mak didn't work.
>  
> Out of curiosity I was then trying to uncomment the target for iupluagl
> in the Makefile in iup/srclua5. I got the following error message:
>  
>
> Tecmake: linking libiupluaim51.so ...
>
> gcc -bundle -undefined dynamic_lookup -o
> ../lib/MacOS106/libiupluaim51.so ../obj/iupluaim51/MacOS106/iuplua_im.o
> -L../lib/MacOS106 -L../lib/MacOS106 -L../../im/lib/MacOS106 -liupim
> -limlua51 -liup -lim -lm
>
> ld: in ../../im/lib/MacOS106/libimlua51.so, can't link with bundle
> (MH_BUNDLE) only dylibs (MH_DYLIB)
>
> collect2: ld returned 1 exit status
>
> make[2]: *** [../lib/MacOS106/libiupluaim51.so] Error 1
>
> make[1]: *** [iupluaim] Error 2
>
> make: *** [iuplua5] Error 2
>  
>  
> Some ideas?
>  
> Kind regards,
>  
> Roman Maire
>