Problem displaying graphics

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem displaying graphics

apeine
Hello fellow Plua programmers,

I was learning how to add a windows bitmap on a Plua program. After
converting a 24-bit to 8-bit windows bitmap, I finally managed to add
the bitmap, using Plural and compiling using command line (see below
for not using Plural to compile).
But I noticed that at least 1 horizontal line at the end of the
graphic is not shown. Is this correct? Do I have to add extra lines
below the graphic so it can disappear?

The program is:
-- bola.lua
screen.clear()  -- I added that myself
bmp, bmp_width, bmp_height = buffer.read("rsrc:/Wbmp/0010")
width, height = screen.mode()
buffer.put(bmp, (width-bmp_width)/2, (height-bmp_height)/2)
buffer.free(bmp)
gui.event()

and the file was compiled using the following command line:

plua2c -name bola -cid ARPJ -o bola.prc bola.lua Wbmp000a.bin

I also tried to use Plural 2.0.2, but I always got a message error
such as:
"Plua2c didn't create prc file.
Error at line \...\plua2c.exe: Invalid resource "C:\...\Wbmp000a.bin",
where ... is the directory...

I´ve added a screen at the root of files at the Plua group. (screen.gif).

Reply | Threaded
Open this post in threaded view
|

Re: Problem displaying graphics

migueletto-2
Hi,

> I was learning how to add a windows bitmap on a Plua program. After
> converting a 24-bit to 8-bit windows bitmap, I finally managed to add
> the bitmap, using Plural and compiling using command line (see below
> for not using Plural to compile).
> But I noticed that at least 1 horizontal line at the end of the
> graphic is not shown. Is this correct? Do I have to add extra lines
> below the graphic so it can disappear?

This is a Plua bug, which I think is fixed now. Do you have the
compiled PRC so I can test it ?

Regards,
Marcio.

Reply | Threaded
Open this post in threaded view
|

Re: Problem displaying graphics

apeine
Hello Márcio,

I've added the file to files link in Plua group. The name is face.prc.
Regards,

Alfredo

--- In [hidden email], "migueletto" <migueletto@...> wrote:

>
> Hi,
>
> > I was learning how to add a windows bitmap on a Plua program. After
> > converting a 24-bit to 8-bit windows bitmap, I finally managed to add
> > the bitmap, using Plural and compiling using command line (see below
> > for not using Plural to compile).
> > But I noticed that at least 1 horizontal line at the end of the
> > graphic is not shown. Is this correct? Do I have to add extra lines
> > below the graphic so it can disappear?
>
> This is a Plua bug, which I think is fixed now. Do you have the
> compiled PRC so I can test it ?
>
> Regards,
> Marcio.
>