PGP Tool with Lua Bindings, was Re: [ANN} LuaSec 0.7 released

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

PGP Tool with Lua Bindings, was Re: [ANN} LuaSec 0.7 released

Russell Haley
Hi, 

Since security minded people will be reading these posts, I wanted to mention I found an BSD licensed PGP library with Lua bindings, but don't have the focus to actually do anything with it. The library is called netpgp and is available here: 


I was able to get the base library working and did some tests, but couldn't get the lua bindings to build (lack of make skills). I was able to verify a signed file, but couldn't get detached signatures to work and got a SIGSEV when mucking with the keyring library.

The author hasn't responded to an initial hello message so I'm not sure if it's maintained, but it would sure be nice to see this tool in LuaRocks if anyone is so inclined. 

Thanks to Bruno and everyone keeping Lua communications secure. 

Cheers, 
Russ

On Mon, Jul 2, 2018 at 6:52 AM, Matthew Wild <[hidden email]> wrote:
On 2 July 2018 at 14:13, Bruno Silvestre <[hidden email]> wrote:
> LuaSec depends on OpenSSL, and integrates with LuaSocket to make it
> easy to add secure connections to any Lua applications or scripts.
>
> This version is compatible with Lua 5.1, 5.2, 5.3, and LuaJIT.

LuaSec is an essential dependency of Prosody, and it has progressed a
long way since we first started using it.

Thanks Bruno for your continued maintainership, and to everyone who
has contributed features and fixes to recent releases!

Regards,
Matthew