Odd Plua behavior on Palm TX

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Odd Plua behavior on Palm TX

bh77a
Friday, January 13, 2006

Good evening,

Have been using Plua 2.0b4 on my TX for a while now.  All in all it works very well, but I
have run across two issues and are needing to know if they are issues with this current
Plua build or if they are device specific TX issues...

The first issue revolves around using the memo pad feature.  After entering code,
sometimes it is saved and sometimes it isn't.  There doesn't seem to be any rhyme or
reason to when it is actually saved or not (by this I mean that I can enter code, exit Plua
and then return to Plua later, open the previous memo file and the text may be totally
gone or my most recent additions gone)

The second issue revolves around the online help feature of Plua.  In version 1, this
worked very nicely... select the key word in the text, tap the find icon a help dialog popped
up with information.  It was also possible to pop up the index list and browse through.  On
my TX, selecting a key word and tapping find does nothing.  Tapping the find icon will
occasionally bring up the help dialog.  When the dialog does appear, the list is scrollable,
but none of the items allow me to view them (as they did in version 1 of Plua).

Hope that this makes sense.  If anyone can shed light on whether or not these are Plua
issues or device specific issues, I would be most grateful.

Thanks






 
Yahoo! Groups Links

<*> To visit your group on the web, go to:
    http://groups.yahoo.com/group/plua/

<*> To unsubscribe from this group, send an email to:
    [hidden email]

<*> Your use of Yahoo! Groups is subject to:
    http://docs.yahoo.com/info/terms/
 


Reply | Threaded
Open this post in threaded view
|

Re: Odd Plua behavior on Palm TX

bh77a
Plua version 1.1 has this same issue on my TX.  The Help file works
a bit more accurately, but still doesn't allow for selection/goto of
an item in the popup list.

Any takers?

--- In [hidden email], "bh77a" <brianandlori@t...> wrote:
>
> Friday, January 13, 2006
>
> Good evening,
>
> Have been using Plua 2.0b4 on my TX for a while now.  All in all
it works very well, but I
> have run across two issues and are needing to know if they are
issues with this current
> Plua build or if they are device specific TX issues...
>
> The first issue revolves around using the memo pad feature.  After
entering code,
> sometimes it is saved and sometimes it isn't.  There doesn't seem
to be any rhyme or
> reason to when it is actually saved or not (by this I mean that I
can enter code, exit Plua
> and then return to Plua later, open the previous memo file and the
text may be totally
> gone or my most recent additions gone)
>
> The second issue revolves around the online help feature of Plua.  
In version 1, this
> worked very nicely... select the key word in the text, tap the
find icon a help dialog popped
> up with information.  It was also possible to pop up the index
list and browse through.  On
> my TX, selecting a key word and tapping find does nothing.  
Tapping the find icon will
> occasionally bring up the help dialog.  When the dialog does
appear, the list is scrollable,
> but none of the items allow me to view them (as they did in
version 1 of Plua).
>
> Hope that this makes sense.  If anyone can shed light on whether
or not these are Plua
> issues or device specific issues, I would be most grateful.
>
> Thanks
>






 
Yahoo! Groups Links

<*> To visit your group on the web, go to:
    http://groups.yahoo.com/group/plua/

<*> To unsubscribe from this group, send an email to:
    [hidden email]

<*> Your use of Yahoo! Groups is subject to:
    http://docs.yahoo.com/info/terms/
 



Reply | Threaded
Open this post in threaded view
|

Plua/Memo Issues on NVFS devices? (Re: Odd Plua behavior on Palm TX)

bh77a
Well....

Here is what my testing has determined.

1.  Create and edit a memo in Plua 1 or 2 and the next time a reset occurs all but the first
string is erased.
2.  Edit an existing memo in Plua 1 or 2 and the next time a reset occurs all but the
previous test is erased (provided the memo was created via a different program, ie
Memos).
3.  Create a memo with Plua source in it with an alternate memo editor and the text
survives a soft reset.

My question is whether or not this might be an issue with NVFS devices or is it just a TX
specific question.  I have read that there are issues with databases not being properly
closed having the contents erased with the NVFS device soft resets.

Any feedback from a user with a TE2, Treo 650, T5, LifeDrive or TX would be much
appreciated...

--- In [hidden email], "bh77a" <brianandlori@t...> wrote:

>
> Plua version 1.1 has this same issue on my TX.  The Help file works
> a bit more accurately, but still doesn't allow for selection/goto of
> an item in the popup list.
>
> Any takers?
>
> --- In [hidden email], "bh77a" <brianandlori@t...> wrote:
> >
> > Friday, January 13, 2006
> >
> > Good evening,
> >
> > Have been using Plua 2.0b4 on my TX for a while now.  All in all
> it works very well, but I
> > have run across two issues and are needing to know if they are
> issues with this current
> > Plua build or if they are device specific TX issues...
> >
> > The first issue revolves around using the memo pad feature.  After
> entering code,
> > sometimes it is saved and sometimes it isn't.  There doesn't seem
> to be any rhyme or
> > reason to when it is actually saved or not (by this I mean that I
> can enter code, exit Plua
> > and then return to Plua later, open the previous memo file and the
> text may be totally
> > gone or my most recent additions gone)
> >
> > The second issue revolves around the online help feature of Plua.  
> In version 1, this
> > worked very nicely... select the key word in the text, tap the
> find icon a help dialog popped
> > up with information.  It was also possible to pop up the index
> list and browse through.  On
> > my TX, selecting a key word and tapping find does nothing.  
> Tapping the find icon will
> > occasionally bring up the help dialog.  When the dialog does
> appear, the list is scrollable,
> > but none of the items allow me to view them (as they did in
> version 1 of Plua).
> >
> > Hope that this makes sense.  If anyone can shed light on whether
> or not these are Plua
> > issues or device specific issues, I would be most grateful.
> >
> > Thanks
> >
>





 
Yahoo! Groups Links

<*> To visit your group on the web, go to:
    http://groups.yahoo.com/group/plua/

<*> To unsubscribe from this group, send an email to:
    [hidden email]

<*> Your use of Yahoo! Groups is subject to:
    http://docs.yahoo.com/info/terms/
 


Reply | Threaded
Open this post in threaded view
|

Plua/Memo Issues on NVFS devices? (Re: Odd Plua behavior on Palm TX)

migueletto
Hi,

--- In [hidden email], "bh77a" <brianandlori@t...> wrote:
> My question is whether or not this might be an issue with NVFS
devices or is it just a TX
> specific question.  I have read that there are issues with databases
not being properly
> closed having the contents erased with the NVFS device soft resets.

I can not verify this since I do not have one of these devices. A
simulator is not an option, since my environment is Linux only.

I found issues with MemoPad writing since the first PalmOS 5 release,
but until now it seemed a workaround was possible. Maybe MemoPad
support will be dropped in the future.

Regards,
Marcio.





 
Yahoo! Groups Links

<*> To visit your group on the web, go to:
    http://groups.yahoo.com/group/plua/

<*> To unsubscribe from this group, send an email to:
    [hidden email]

<*> Your use of Yahoo! Groups is subject to:
    http://docs.yahoo.com/info/terms/
 


Reply | Threaded
Open this post in threaded view
|

Plua/Memo Issues on NVFS devices? (Re: Odd Plua behavior on Palm TX)

bh77a
Hi Marcio,

Thanks for the response.  Memo Pad functionality is limited, meaning that if I create and
edit the memo in either the default memo application or PSMemo, all works well.  Plua
runs/compiles these memos fine and they are not lost on reset...  Therefore, memo
functionality is possible, just the direct editing/creation via Plua causes problems...  It is
almost like Plua doesn't "save" the information to the database successfully.

You might want to check out this link, notably the comment about DmCloseDatabase and
the issues with resetting...

http://www.palmpowerups.com/modules.php?name=Forums&file=viewtopic&t=407

Not sure if it will be true for Plua but it couldn't hurt to examine it as a possibility.

Thanks for your feedback,
Brian

--- In [hidden email], "migueletto" <mmand@u...> wrote:

>
> Hi,
>
> --- In [hidden email], "bh77a" <brianandlori@t...> wrote:
> > My question is whether or not this might be an issue with NVFS
> devices or is it just a TX
> > specific question.  I have read that there are issues with databases
> not being properly
> > closed having the contents erased with the NVFS device soft resets.
>
> I can not verify this since I do not have one of these devices. A
> simulator is not an option, since my environment is Linux only.
>
> I found issues with MemoPad writing since the first PalmOS 5 release,
> but until now it seemed a workaround was possible. Maybe MemoPad
> support will be dropped in the future.
>
> Regards,
> Marcio.
>






 
Yahoo! Groups Links

<*> To visit your group on the web, go to:
    http://groups.yahoo.com/group/plua/

<*> To unsubscribe from this group, send an email to:
    [hidden email]

<*> Your use of Yahoo! Groups is subject to:
    http://docs.yahoo.com/info/terms/
 


Reply | Threaded
Open this post in threaded view
|

Plua/Memo Issues on NVFS devices? (Re: Odd Plua behavior on Palm TX)

mebeddo
I have a Treo 650. Installed plua-2.0b4 on it. I also notice that I
can't get help on Plua - the index is there, I can scroll it, but
tapping on an item goes ignored. Phone is running Palm OS Garnet v 5.4.8

- Mike Beddo





 
Yahoo! Groups Links

<*> To visit your group on the web, go to:
    http://groups.yahoo.com/group/plua/

<*> To unsubscribe from this group, send an email to:
    [hidden email]

<*> Your use of Yahoo! Groups is subject to:
    http://docs.yahoo.com/info/terms/
 


Reply | Threaded
Open this post in threaded view
|

Plua/Memo Issues on NVFS devices? (Re: Odd Plua behavior on Palm TX)

bh77a
Hi Mike,

Thanks for confirming this issue.  It seems to be something to do with the help form and
the 5-way navigator functionality of the newer Palms... just my guess anyways.

Do you create source files within Plua's memo features?   If so, upon soft reset are non-
hotsynced source memos empty, having only the first line / title and none of the
remaining text?



--- In [hidden email], "mebeddo" <mebeddo@y...> wrote:
>
> I have a Treo 650. Installed plua-2.0b4 on it. I also notice that I
> can't get help on Plua - the index is there, I can scroll it, but
> tapping on an item goes ignored. Phone is running Palm OS Garnet v 5.4.8
>
> - Mike Beddo
>





 
Yahoo! Groups Links

<*> To visit your group on the web, go to:
    http://groups.yahoo.com/group/plua/

<*> To unsubscribe from this group, send an email to:
    [hidden email]

<*> Your use of Yahoo! Groups is subject to:
    http://docs.yahoo.com/info/terms/