Menu artifacts when double-buffering on hi-res devices.

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Menu artifacts when double-buffering on hi-res devices.

Pal-3
I have noticed that on 160x160 devices, full screen with menu double-buffering works fine.
However, on 320x320 devices if the menu is manipulated during a loop, menu chunks are
left in various unwanted places on the screen.

I thought I was coding wrong, but even simple programs, in which buffering used, behave
this way. The same programs run in low-res on the emulator work fine.

For an example of this, view Marcio's "Life" application in the Demo directory of plua-
examples. During runtime, if you tap on the menu, then tap on an item, artifacts appear and
other general menu chaos ensues.

Can anyone else confirm?


Cheers,
Pal




Reply | Threaded
Open this post in threaded view
|

Re: Menu artifacts when double-buffering on hi-res devices.

Pal-3
I had a friend load Marcio's "Life" app and he had no problems with his screen. He has a
T3, whereas I have a T|X. Would anyone else like to install the file and report?

I've temporarily uploaded a screen capture in the Files section of what my screen looks like
when menu garbage appears due to double-buffering. This does not occur for apps with
no double-buffering.

The file is called "1456.jpg". I used a program called Zgrab to capture the images on the
device.

Thanks,
Pal



--- In [hidden email], "Pal" <greenchile505@...> wrote:
>
> I have noticed that on 160x160 devices, full screen with menu double-buffering works
fine.
> However, on 320x320 devices if the menu is manipulated during a loop, menu chunks
are
> left in various unwanted places on the screen.
>
> I thought I was coding wrong, but even simple programs, in which buffering used,
behave
> this way. The same programs run in low-res on the emulator work fine.
>
> For an example of this, view Marcio's "Life" application in the Demo directory of plua-
> examples. During runtime, if you tap on the menu, then tap on an item, artifacts appear
and
> other general menu chaos ensues.
>
> Can anyone else confirm?
>
>
> Cheers,
> Pal
>



Reply | Threaded
Open this post in threaded view
|

Re: Menu artifacts when double-buffering on hi-res devices.

migueletto-2
In reply to this post by Pal-3
Hi,

--- In [hidden email], "Pal" <greenchile505@...> wrote:

> I have noticed that on 160x160 devices, full screen with menu
double-buffering works fine.
> However, on 320x320 devices if the menu is manipulated during a
loop, menu chunks are
> left in various unwanted places on the screen.

This problem is fixed for the next release.

Regards,
Marcio.

Reply | Threaded
Open this post in threaded view
|

Re: Menu artifacts when double-buffering on hi-res devices.

Pal-3
--- In [hidden email], "migueletto" <migueletto@...> wrote:

> This problem is fixed for the next release.

Thank you for verifying this.


Pal