Lua5.3 and MIDI

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Lua5.3 and MIDI

Mario Buoninfante
Hi,

Thanks for the suggestion.
Unfortunately LuaMidi (https://www.pjb.com.au/comp/lua/MIDI.html) seems to deal with MIDI files ('off-line') but not with real-time MIDI (ie MIDI to/from hardware device via USB), that is what I'm looking for.

Cheers,
Mario
Reply | Threaded
Open this post in threaded view
|

Re: Lua5.3 and MIDI

Dirk Laurie-2
Op Wo. 10 Jul. 2019 om 02:19 het Mario Buoninfante
<[hidden email]> geskryf:

> Thanks for the suggestion.
> Unfortunately LuaMidi (https://www.pjb.com.au/comp/lua/MIDI.html) seems to deal with MIDI files ('off-line') but not with real-time MIDI (ie MIDI to/from hardware device via USB), that is what I'm looking for.

How hard can it be to refactor the code to call import/export routines
instead of accessing the next line/record?

v
Reply | Threaded
Open this post in threaded view
|

Re: Lua5.3 and MIDI

v
On Wed, 2019-07-10 at 08:10 +0200, Dirk Laurie wrote:

> Op Wo. 10 Jul. 2019 om 02:19 het Mario Buoninfante
> <[hidden email]> geskryf:
>
> > Thanks for the suggestion.
> > Unfortunately LuaMidi (https://www.pjb.com.au/comp/lua/MIDI.html)
> > seems to deal with MIDI files ('off-line') but not with real-time
> > MIDI (ie MIDI to/from hardware device via USB), that is what I'm
> > looking for.
>
> How hard can it be to refactor the code to call import/export
> routines
> instead of accessing the next line/record?
>

I don't think this is a good idea then. If you need real-time midi,
take a look at https://github.com/stetre/luajack (Full Lua 5.3 support,
no luarocks package). It is Lua bindings for cross-platform JACK audio
connection kit.
It require extra configuration, but is right tool if you want to do
advanced audio (including midi routing). There seem to be some quirks
on Windows (only 32-bit applications?), but after some work it
functions flawlessly on linux even together with pulseaudio. I probably
can help if you'll want to install it onto linux.

--
v <[hidden email]>