Lua5.3 and MIDI

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Lua5.3 and MIDI

Mario Buoninfante
Hi everybody,

This is the first time I write on this mailing list, and I've got a question someone probably has already answered in the past :)
That said, I had a 'quick look' at the mailing list archive, and I couldn't find my answer. I hope I didn't miss any thread.

Is anyone aware of any MIDI modules compatible with Lua5.3?
The only 2  MIDI modules I've found are:


and both aren't compatible with 5.3.

PS: maybe it's just me, since I'm only now seriously approaching Lua, but I'm struggling a bit with Lua5.3 in finding compatible modules.

Cheers,
Mario
v
Reply | Threaded
Open this post in threaded view
|

Re: Lua5.3 and MIDI

v
On Tue, 2019-07-09 at 22:29 +0100, Mario Buoninfante wrote:
> Is anyone aware of any MIDI modules compatible with Lua5.3?
> The only 2  MIDI modules I've found are:
> Cheers,
> Mario

One I used: https://www.pjb.com.au/comp/lua/MIDI.html. It's done in
pure Lua, compatible with Lua 5.3 and can be installed via luarocks
with

> luarocks install midi

Another option I know is https://github.com/PedroAlvesV/LuaMidi (pure
Lua as wel), but I'm not aware of its Lua 5.3 compatiblity. It is known
as `luamidi` in luarocks.

Hope this helps!

--
v <[hidden email]>


Reply | Threaded
Open this post in threaded view
|

Re: Lua5.3 and MIDI

Coda Highland
In reply to this post by Mario Buoninfante
On Tue, Jul 9, 2019 at 4:29 PM Mario Buoninfante <[hidden email]> wrote:
Hi everybody,

This is the first time I write on this mailing list, and I've got a question someone probably has already answered in the past :)
That said, I had a 'quick look' at the mailing list archive, and I couldn't find my answer. I hope I didn't miss any thread.

Is anyone aware of any MIDI modules compatible with Lua5.3?
The only 2  MIDI modules I've found are:


and both aren't compatible with 5.3.

PS: maybe it's just me, since I'm only now seriously approaching Lua, but I'm struggling a bit with Lua5.3 in finding compatible modules.

Cheers,
Mario

I wrote one for 5.1 a loooong time ago, but it was closed-source and I don't have access to it anymore.

What are you looking for in a MIDI module? Do you just need to be able to manipulate MIDI data (e.g. MIDI files, or the host application does the I/O), or do you need to be able to interface with a MIDI device directly?

/s/ Adam 
Reply | Threaded
Open this post in threaded view
|

Re: Lua5.3 and MIDI

Dirk Laurie-2
In reply to this post by v
Op Di. 9 Jul. 2019 om 23:42 het v <[hidden email]> geskryf:

>
> On Tue, 2019-07-09 at 22:29 +0100, Mario Buoninfante wrote:
> > Is anyone aware of any MIDI modules compatible with Lua5.3?
> > The only 2  MIDI modules I've found are:
> > Cheers,
> > Mario
>
> One I used: https://www.pjb.com.au/comp/lua/MIDI.html. It's done in
> pure Lua, compatible with Lua 5.3 and can be installed via luarocks
> with
>
> > luarocks install midi

+1. The author is a musician and the interface is very direct. You
need to have good MIDI documentation at hand; www.midi.org supplies
that. Two Lua formats are offered, one using on-offs as in MIDI, the
other using durations which some users may prefer.

-- Dirk