Lua 5.1 for Fedora Core 5?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Lua 5.1 for Fedora Core 5?

John D. Ramsdell-2
Is anyone working on packaging Lua 5.1 for Fedora Core 5?  If not,
I'll take on the task.

John

Reply | Threaded
Open this post in threaded view
|

Re: Lua 5.1 for Fedora Core 5?

Antonio Scuri

> Is anyone working on packaging Lua 5.1 for Fedora Core 5?  If not,
> I'll take on the task.

  What "packaging" are you talking about? You mean an RPM?

LuaBinaries will be available soon. I'm still dowloading FC5. It will take some time to finish download, install and build Lua. If you can wait one or two days...

Best,
scuri


Reply | Threaded
Open this post in threaded view
|

Re: Lua 5.1 for Fedora Core 5?

John D. Ramsdell-2
In reply to this post by John D. Ramsdell-2
> Date: Fri, 24 Mar 2006 11:55:21 -0300
> From: Antonio Scuri <[hidden email]>
> Subject: Re: Lua 5.1 for Fedora Core 5?
> To: Lua list <[hidden email]>
> Message-ID: <7.0.1.0.2.20060324114925.02679df0@...>
> Content-Type: text/plain; charset="us-ascii"; format=flowed
> 
> 
> > > Is anyone working on packaging Lua 5.1 for Fedora Core 5?  If not,
> > > I'll take on the task.
> 
>    What "packaging" are you talking about? You mean an RPM?

Antonio,

I'm talking about submitting an RPM to fedora.redhat.com extras so
that FC5 users need only type "yum install lua" to get Lua, and "yum
update" to get the latest revision of lua once it has been installed.
The same should be done for Debian distros, but I confess I don't know
that procedure.  After you install FC5, type "yum install lua" as
root, and you'll see what I mean.

John

Reply | Threaded
Open this post in threaded view
|

Re: Lua 5.1 for Fedora Core 5?

Alex Queiroz
Hallo,

On 24 Mar 2006 13:26:46 -0500, John D. Ramsdell <[hidden email]> wrote:
>
> I'm talking about submitting an RPM to fedora.redhat.com extras so
> that FC5 users need only type "yum install lua" to get Lua, and "yum
> update" to get the latest revision of lua once it has been installed.
> The same should be done for Debian distros, but I confess I don't know
> that procedure.  After you install FC5, type "yum install lua" as
> root, and you'll see what I mean.
>

     Lua is already in Debian unstable.

--
-alex
http://www.ventonegro.org/


Reply | Threaded
Open this post in threaded view
|

Re: Lua 5.1 for Fedora Core 5?

Antonio Scuri
In reply to this post by John D. Ramsdell-2
At 15:26 24/3/2006, John D. Ramsdell wrote:
I'm talking about submitting an RPM to fedora.redhat.com extras so
that FC5 users need only type "yum install lua" to get Lua, and "yum
update" to get the latest revision of lua once it has been installed.
The same should be done for Debian distros, but I confess I don't know
that procedure.  After you install FC5, type "yum install lua" as
root, and you'll see what I mean.

  Ok. We have a RPM spec at LuaForge in:

      http://luaforge.net/projects/luarpms/

They are for Lua 5.0.2. And we would like to add support for Lua 5.1, but using the LuaBinaries definitions:

      http://luabinaries.luaforge.net/

In fact, the only important parameter is the name of the executables and libraries.

  It will be better to do:

     "yum install lua5.1"

  So in the future, several Lua versions can coexist in the same system.

  What you think?  Let me know if I can help.

Best,
scuri