LUA: Como atualizar a versao do im iup cd do lua5.1 para lua 5.3

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

LUA: Como atualizar a versao do im iup cd do lua5.1 para lua 5.3

Rodrigo Mendonça

Gostaria de uma orientacao.

Atualmente tenho a seguinte estrutura.

SO UBUNTU 12.04.1 x64

LUA 5.1.5

IM IM-3.8_Linux26g4_64.lib

CD CD-5.5.1_Linux26g4_64.lib

IUP IUP-36-5.5.1_Linux26g4_64.lib

POSTGRESQL 9.1

Acontece que ao reinstalar o sistema nao obtive sucesso devido aos sucessivos erros junto ao libreadline, e outros. Fiz a instalacao tanto pelo apt-get quanto baixando pelo repositorio do Ubuntu(Ubuntu Packages).

Olhei no site e pelo q observei o lua5.3 possui im,cd,iup ate o Kernel 3.3. Nao me vejo com gabarito suficente para fazer esta migração sozinho. Diante do fato consulto voces. Voces poderiam me dar uma orientacao de quais versoes baixar, pois gostaria de migrar para o lua5.3 utilizando o Ubuntu 14 x64 ?

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: LUA: Como atualizar a versao do im iup cd do lua5.1 para lua 5.3

Denis Dos Santos Silva
pra instalar a libreadline use:

sudo apt-get install libreadline libreadline-dev


Rodrigo a diferença entre as versões nas questão de integração com C e modulos (ou packages) feitos em LUA é grande. Tornando incompativéis (ainda mais bibliotecas feitas em C - binding).

Vai ser mais fácil instalar a versão 5.1.5 e seguir os requisitos do IM,CD,UIP - nem que seja manual e/ou via luarocks/luadist.

No site oficial do im,cd,uip fala em lua 5.1.5

A versão do kernel nao interfere muito pro Lua. A observação é quanto a arquitetura 32 ou 64-bits.

A respeito do PgSQL 9.1 -> como usa a comunicação via sockets não há problemas maiores.


Em quarta-feira, 16 de março de 2016 20:03:57 UTC-3, Rodrigo Mendonça escreveu:

Gostaria de uma orientacao.

Atualmente tenho a seguinte estrutura.

SO UBUNTU 12.04.1 x64

LUA 5.1.5

IM IM-3.8_Linux26g4_64.lib

CD CD-5.5.1_Linux26g4_64.lib

IUP IUP-36-5.5.1_Linux26g4_64.lib

POSTGRESQL 9.1

Acontece que ao reinstalar o sistema nao obtive sucesso devido aos sucessivos erros junto ao libreadline, e outros. Fiz a instalacao tanto pelo apt-get quanto baixando pelo repositorio do Ubuntu(Ubuntu Packages).

Olhei no site e pelo q observei o lua5.3 possui im,cd,iup ate o Kernel 3.3. Nao me vejo com gabarito suficente para fazer esta migração sozinho. Diante do fato consulto voces. Voces poderiam me dar uma orientacao de quais versoes baixar, pois gostaria de migrar para o lua5.3 utilizando o Ubuntu 14 x64 ?

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: LUA: Como atualizar a versao do im iup cd do lua5.1 para lua 5.3

Antonio Scuri
  Olá Rodrigo,

  Quanto a IUP, CD, IM e LuaBinaries para Lua 5.3 todos já possuem pacotes para Ubuntu 14 (Linux313_64).

[]s
Scuri


2016-03-16 21:57 GMT-03:00 Denis Dos Santos Silva <[hidden email]>:
pra instalar a libreadline use:

sudo apt-get install libreadline libreadline-dev


Rodrigo a diferença entre as versões nas questão de integração com C e modulos (ou packages) feitos em LUA é grande. Tornando incompativéis (ainda mais bibliotecas feitas em C - binding).

Vai ser mais fácil instalar a versão 5.1.5 e seguir os requisitos do IM,CD,UIP - nem que seja manual e/ou via luarocks/luadist.

No site oficial do im,cd,uip fala em lua 5.1.5

A versão do kernel nao interfere muito pro Lua. A observação é quanto a arquitetura 32 ou 64-bits.

A respeito do PgSQL 9.1 -> como usa a comunicação via sockets não há problemas maiores.


Em quarta-feira, 16 de março de 2016 20:03:57 UTC-3, Rodrigo Mendonça escreveu:

Gostaria de uma orientacao.

Atualmente tenho a seguinte estrutura.

SO UBUNTU 12.04.1 x64

LUA 5.1.5

IM IM-3.8_Linux26g4_64.lib

CD CD-5.5.1_Linux26g4_64.lib

IUP IUP-36-5.5.1_Linux26g4_64.lib

POSTGRESQL 9.1

Acontece que ao reinstalar o sistema nao obtive sucesso devido aos sucessivos erros junto ao libreadline, e outros. Fiz a instalacao tanto pelo apt-get quanto baixando pelo repositorio do Ubuntu(Ubuntu Packages).

Olhei no site e pelo q observei o lua5.3 possui im,cd,iup ate o Kernel 3.3. Nao me vejo com gabarito suficente para fazer esta migração sozinho. Diante do fato consulto voces. Voces poderiam me dar uma orientacao de quais versoes baixar, pois gostaria de migrar para o lua5.3 utilizando o Ubuntu 14 x64 ?

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: LUA: Como atualizar a versao do im iup cd do lua5.1 para lua 5.3

Denis Dos Santos Silva
In reply to this post by Rodrigo Mendonça
acho que este link pode te ajudar: https://sourceforge.net/projects/iup/files/3.17/Linux%20Libraries/




---

Linux Libraries Download

Here you will find packages for Linux systems. Each package contains pre-compiled binaries for the specified platform.

Libraries packages for Linux contain dynamic libraries (.so), static libraries (.a), and include files (*.h). So they contain run time and development files together in the same package.

Libraries are in the root of the package, and include files are inside an "include" folder.

Available Platforms

For the newest Linux systems, use the "Linux26g4" (32bits) and "Linux26g4_64" (64bits) packages.

Here is a list of packages and some details of the platforms where they were built:

  • Linux24: Red Hat 7.3 (x86) / Kernel 2.4 / gcc 2.95 / Open Motif 2.1
  • Linux24g3: CentOS 3.9 (x86) / Kernel 2.4 / gcc 3.2 / Open Motif 2.2
  • Linux24g3_64: Red Hat E.L. WS 3 (x64) / Kernel 2.4 / gcc 3.2 / Open Motif 2.2
  • Linux26: CentOS 4.6 (x86) / Kernel 2.6 / gcc 3.4 / Open Motif 2.2
  • Linux26_64: CentOS 4.6 (x64) / Kernel 2.6 / gcc 3.4 / Open Motif 2.2
  • Linux26g4: Ubuntu 10.04 (x86) / Kernel 2.6 / gcc 4.4 / GTK 2.20
  • Linux26g4_64: Ubuntu 10.04 (x64) / Kernel 2.6 / gcc 4.4 / GTK 2.20
  • Linux30: Ubuntu 11.10 (x86) / Kernel 3.0 / gcc 4.6 / GTK 2.24
  • Linux30_64: Ubuntu 11.10 (x64) / Kernel 3.0 / gcc 4.6 / GTK 2.24

Installation

The packages include also scripts to install the run time files or the development files in the system. Scripts were tested only in Ubuntu, but with minor changes they can work in any Linux system.

For more information about installation and building from sources, see the Building Lua, IM, CD and IUP in Linux documentation.

More Information

For more information on the available download packages, see the Tecgraf/PUC-Rio Library Download Tips documentation.


---



Em quarta-feira, 16 de março de 2016 20:03:57 UTC-3, Rodrigo Mendonça escreveu:

Gostaria de uma orientacao.

Atualmente tenho a seguinte estrutura.

SO UBUNTU 12.04.1 x64

LUA 5.1.5

IM IM-3.8_Linux26g4_64.lib

CD CD-5.5.1_Linux26g4_64.lib

IUP IUP-36-5.5.1_Linux26g4_64.lib

POSTGRESQL 9.1

Acontece que ao reinstalar o sistema nao obtive sucesso devido aos sucessivos erros junto ao libreadline, e outros. Fiz a instalacao tanto pelo apt-get quanto baixando pelo repositorio do Ubuntu(Ubuntu Packages).

Olhei no site e pelo q observei o lua5.3 possui im,cd,iup ate o Kernel 3.3. Nao me vejo com gabarito suficente para fazer esta migração sozinho. Diante do fato consulto voces. Voces poderiam me dar uma orientacao de quais versoes baixar, pois gostaria de migrar para o lua5.3 utilizando o Ubuntu 14 x64 ?

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.