Instalação lua, Ubutnu 14.04

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Instalação lua, Ubutnu 14.04

joelson gai
Boa noite pessoal, eu instalei a ultima versão e está ok.
Quero testar o IUP só que não importa o modulo está dando esse erro:

require("iuplua")
stdin:1: module 'iuplua' not found:


Dados da instalação.
       $lua
       Lua 5.3.2  Copyright (C) 1994-2015 Lua.org, PUC-Rio

Instalei o IUP

$ sudo ./install

“libiupcd.so” -> “/usr/lib/libiupcd.so”
“libiupcontrols.so” -> “/usr/lib/libiupcontrols.so”
“libiupglcontrols.so” -> “/usr/lib/libiupglcontrols.so”
“libiupgl.so” -> “/usr/lib/libiupgl.so”
“libiupimglib.so” -> “/usr/lib/libiupimglib.so”
“libiupim.so” -> “/usr/lib/libiupim.so”
“libiupmatrixex.so” -> “/usr/lib/libiupmatrixex.so”
“libiup_mglplot.so” -> “/usr/lib/libiup_mglplot.so”
“libiup_plot.so” -> “/usr/lib/libiup_plot.so”
“libiup_pplot.so” -> “/usr/lib/libiup_pplot.so”
“libiup_scintilla.so” -> “/usr/lib/libiup_scintilla.so”
“libiup.so” -> “/usr/lib/libiup.so”
“libiuptuio.so” -> “/usr/lib/libiuptuio.so”
“libiupweb.so” -> “/usr/lib/libiupweb.so”


$sudo ./config_lua_module

“iuplua.so” -> “/usr/lib/libiuplua51.so”
“iupluacontrols.so” -> “/usr/lib/libiupluacontrols51.so”
“iupluacd.so” -> “/usr/lib/libiupluacd51.so”
“iupluagl.so” -> “/usr/lib/libiupluagl51.so”
“iuplua_pplot.so” -> “/usr/lib/libiuplua_pplot51.so”
“iupluaim.so” -> “/usr/lib/libiupluaim51.so”
“iupluaimglib.so” -> “/usr/lib/libiupluaimglib51.so”
“iupluatuio.so” -> “/usr/lib/libiupluatuio51.so”

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Instalação lua, Ubutnu 14.04

Denis Dos Santos Silva
mano, eu nao uso o iup mas pelo visto a versao compativel é a 5.1.4 conforme o site dos desenvolvedores

link abaixo mostra como instalar (quase que do zero):
http://webserver2.tecgraf.puc-rio.br/iup/
menu à esquerda "Guide" -> "Building Lua, IM, CD and IUP in Linux"


Em terça-feira, 2 de fevereiro de 2016 22:13:02 UTC-2, joelson gai escreveu:
Boa noite pessoal, eu instalei a ultima versão e está ok.
Quero testar o IUP só que não importa o modulo está dando esse erro:

require("iuplua")
stdin:1: module 'iuplua' not found:


Dados da instalação.
       $lua
       Lua 5.3.2  Copyright (C) 1994-2015 Lua.org, PUC-Rio

Instalei o IUP

$ sudo ./install

“libiupcd.so” -> “/usr/lib/libiupcd.so”
“libiupcontrols.so” -> “/usr/lib/libiupcontrols.so”
“libiupglcontrols.so” -> “/usr/lib/libiupglcontrols.so”
“libiupgl.so” -> “/usr/lib/libiupgl.so”
“libiupimglib.so” -> “/usr/lib/libiupimglib.so”
“libiupim.so” -> “/usr/lib/libiupim.so”
“libiupmatrixex.so” -> “/usr/lib/libiupmatrixex.so”
“libiup_mglplot.so” -> “/usr/lib/libiup_mglplot.so”
“libiup_plot.so” -> “/usr/lib/libiup_plot.so”
“libiup_pplot.so” -> “/usr/lib/libiup_pplot.so”
“libiup_scintilla.so” -> “/usr/lib/libiup_scintilla.so”
“libiup.so” -> “/usr/lib/libiup.so”
“libiuptuio.so” -> “/usr/lib/libiuptuio.so”
“libiupweb.so” -> “/usr/lib/libiupweb.so”


$sudo ./config_lua_module

“iuplua.so” -> “/usr/lib/libiuplua51.so”
“iupluacontrols.so” -> “/usr/lib/libiupluacontrols51.so”
“iupluacd.so” -> “/usr/lib/libiupluacd51.so”
“iupluagl.so” -> “/usr/lib/libiupluagl51.so”
“iuplua_pplot.so” -> “/usr/lib/libiuplua_pplot51.so”
“iupluaim.so” -> “/usr/lib/libiupluaim51.so”
“iupluaimglib.so” -> “/usr/lib/libiupluaimglib51.so”
“iupluatuio.so” -> “/usr/lib/libiupluatuio51.so”

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Instalação lua, Ubutnu 14.04

joelson gai
In reply to this post by joelson gai
Consegui instalar, era problema na configuração do CPATH da biblioteca.

Obrigado a todos

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.