Emulator error.

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Emulator error.

Pal-3
I wrote a quick app, and compiled it in OSX, and I receive no errors from the compiler.

However, I am getting a weird error from the emulator when I attempt to drag and drop,
which says "Could not install the Palm OS file "PluaApp.prc" because the file is too small to
contain all the information it claims to have."

I then converted the ascii to doc format, loaded, compiled, and ran on real hardware with no
problem.

Ideas?

I suspect it is either a compiler issue or an OSX issue, because before posting this I
attempted to compile this:

-- temp.lua
gui.main()


..and I am getting the same emulator error.


Reply | Threaded
Open this post in threaded view
|

Re: Emulator error.

Pal-3
I should mention version info:

Plua 2.0  Copyright (C) Marcio Migueletto de Andrade
Lua 5.0.3  Copyright (C) 1994-2006 Tecgraf, PUC-Rio
Mac OS X port maintained by Cameron Kaiser: www.floodgap.com/software/macplua/

and

Intel
System Version: Mac OS X 10.5.4 (9E17)
Kernel Version: Darwin 9.4.0


Cheers....


--- In [hidden email], "Pal" <greenchile505@...> wrote:
>
> I wrote a quick app, and compiled it in OSX, and I receive no errors from the compiler.
>
> However, I am getting a weird error from the emulator when I attempt to drag and drop,
> which says "Could not install the Palm OS file "PluaApp.prc" because the file is too small
to
> contain all the information it claims to have."
>
> I then converted the ascii to doc format, loaded, compiled, and ran on real hardware
with no

> problem.
>
> Ideas?
>
> I suspect it is either a compiler issue or an OSX issue, because before posting this I
> attempted to compile this:
>
> -- temp.lua
> gui.main()
>
>
> ..and I am getting the same emulator error.
>



Reply | Threaded
Open this post in threaded view
|

Re: Emulator error.

Cameron Kaiser
In reply to this post by Pal-3
> I wrote a quick app, and compiled it in OSX, and I receive no errors from
> the compiler.
> However, I am getting a weird error from the emulator when I attempt to
> drag and drop,

What's the emulator?

--
------------------------------------ personal: http://www.cameronkaiser.com/ --
  Cameron Kaiser * Floodgap Systems * www.floodgap.com * [hidden email]
-- I like my women like my coffee: weak, cold and bitter. -- Kevin Metcalf ----
Reply | Threaded
Open this post in threaded view
|

Re: Emulator error.

Pal-3
Palm OS Emulator (PowerPC binary).

I can drag-and-drop any PRC onto the emulator, including PRCs compiled with previous
versions of plua2c, and they work.

Thanks for the quick response...



--- In [hidden email], Cameron Kaiser <spectre@...> wrote:

>
> > I wrote a quick app, and compiled it in OSX, and I receive no errors from
> > the compiler.
> > However, I am getting a weird error from the emulator when I attempt to
> > drag and drop,
>
> What's the emulator?
>
> --
> ------------------------------------ personal:
http://www.cameronkaiser.com/ --
>   Cameron Kaiser * Floodgap Systems * www.floodgap.com * ckaiser@...
> -- I like my women like my coffee: weak, cold and bitter. -- Kevin Metcalf ----
>



Reply | Threaded
Open this post in threaded view
|

Re: Re: Emulator error.

Cameron Kaiser
> Palm OS Emulator (PowerPC binary).
>
> I can drag-and-drop any PRC onto the emulator, including PRCs compiled with
> previous versions of plua2c, and they work.
> Thanks for the quick response...

I'm not sure if this is an endian problem from running on Intel, but the
plua2c binary is PPC and should run under Rosetta, so I doubt that's the
issue. Regardless, I made a small running change, which still works locally,
so please tell me if this fixes your problem (PPC binary 10.2+):

        http://www.floodgap.com/software/macplua/mtest.zip

This contains 'pluae2c' (notice name change) to distinguish it from the old
one. If this works, I will substitute the binary into a new release and
change the filename back.

At some point I really need to do an Intel version, I just keep getting
sidetracked (I do have a Core 2 Duo mini I bought for this purpose but other
tasks get in the way).

--
------------------------------------ personal: http://www.cameronkaiser.com/ --
  Cameron Kaiser * Floodgap Systems * www.floodgap.com * [hidden email]
-- So far, my plan to live forever is working exceptionally well! -------------
Reply | Threaded
Open this post in threaded view
|

Re: Emulator error.

Pal-3
Cameron, whatever you did worked. I now have no problem compiling, loading, and
running..

If you want any other info from me just let me know.


Thanks again.

Cheers.

--- In [hidden email], Cameron Kaiser <spectre@...> wrote:

>
> > Palm OS Emulator (PowerPC binary).
> >
> > I can drag-and-drop any PRC onto the emulator, including PRCs compiled with
> > previous versions of plua2c, and they work.
> > Thanks for the quick response...
>
> I'm not sure if this is an endian problem from running on Intel, but the
> plua2c binary is PPC and should run under Rosetta, so I doubt that's the
> issue. Regardless, I made a small running change, which still works locally,
> so please tell me if this fixes your problem (PPC binary 10.2+):
>
> http://www.floodgap.com/software/macplua/mtest.zip
>
> This contains 'pluae2c' (notice name change) to distinguish it from the old
> one. If this works, I will substitute the binary into a new release and
> change the filename back.
>
> At some point I really need to do an Intel version, I just keep getting
> sidetracked (I do have a Core 2 Duo mini I bought for this purpose but other
> tasks get in the way).
>
> --
> ------------------------------------ personal:
http://www.cameronkaiser.com/ --
>   Cameron Kaiser * Floodgap Systems * www.floodgap.com * ckaiser@...
> -- So far, my plan to live forever is working exceptionally well! -------------
>



Reply | Threaded
Open this post in threaded view
|

Re: Re: Emulator error.

Cameron Kaiser
> Cameron, whatever you did worked. I now have no problem compiling, loading,
> and running.

Excellent. I'll rename it back to plua2c and substitute it into a new release.
That should be ready later today (it will be the same binary so you don't
need to redownload it if you already have this one).

--
------------------------------------ personal: http://www.cameronkaiser.com/ --
  Cameron Kaiser * Floodgap Systems * www.floodgap.com * [hidden email]
-- Computers aren't intelligent. They just think they are. --------------------
Reply | Threaded
Open this post in threaded view
|

Re: Re: Emulator error.

Cameron Kaiser
In reply to this post by Pal-3
pluac-2.0i is now available. This version has the fix I made for Pal. If you
already downloaded the test version to use, this is exactly the same. Although
this was in the endian .pdb code, it should have compiled the same, so I'm
not sure exactly what I fixed :) thus I'm keeping the old pluac-2.0 up just in
case. If you have a problem with one, try the other, but 2.0i works fine on my
Tiger G5 and on Pal's Leopard Intel system.

This is a PowerPC binary and is still supported on 10.2.8. Any future feature
releases, however, will be 10.4+ only and (hopefully) Universal.

        http://www.floodgap.com/software/macplua/

--
------------------------------------ personal: http://www.cameronkaiser.com/ --
  Cameron Kaiser * Floodgap Systems * www.floodgap.com * [hidden email]
-- "97% of readers say surveys are rubbish" -- The Register -------------------