Configuring an web server for CGILua

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Configuring an web server for CGILua

leopoldo matias
Hello all,

This is my first message to Lua-list and I hope to learn and later to
share what I have lernt.
I took a look in CGILua. It seems to be very intersting. I would like
to try it, but my experience with web programming is null. For this
reason, I write you to verify the steps I will follow.
1. (done) To install CGILua package - I used Luarocks.
2. (almost done) To choose an web server - I would like to use
Mongoose because it does not require installation and this
characteristic is desirable for me.
3. (to do) To configure the web server - This step requires more
attention. In the configuration file, I did the following changes:

original: # cgi_pattern **.cgi$|**.pl$|**.php$
Changed: cgi_pattern **.cgi$|**.pl$|**.php$|**.cgi$

original: # cgi_interpreter <value>
Changed: cgi_interpreter c:\mongoose\cgilua.cgi

I send you the whole file, but as I know very few about web servers, I
couldn't see other changes.

I got an error about something like WSAPI. How far am I to be
successful? If want to run CGI, not FastCGI, are there many
configurations to do?

CGILua does seem to be hard to use, but the first time always present
something difficulties.

I thank for any contribution.

Leopoldo

mongoose.conf (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Configuring an web server for CGILua

Tomás Guisasola-2
  Hi Leopoldo

> 3. (to do) To configure the web server - This step requires more
> attention. In the configuration file, I did the following changes:
>
> original: # cgi_pattern **.cgi$|**.pl$|**.php$
> Changed: cgi_pattern **.cgi$|**.pl$|**.php$|**.cgi$
>
> original: # cgi_interpreter <value>
> Changed: cgi_interpreter c:\mongoose\cgilua.cgi
  Sorry, but I don't know anything about this WebServer...

> I got an error about something like WSAPI. How far am I to be
> successful? If want to run CGI, not FastCGI, are there many
> configurations to do?
  You should install a launcher which could be wsapi, wsapi-fcgi
or wsapi-xavante.  They can be installed via LuaRocks also.

> CGILua does seem to be hard to use, but the first time always present
> something difficulties.
  CGILua is an old technology but it works fine. Others may prefer
newer approaches like Orbit...

  Regards,
  Tomás