Como Instalar Lua e Löve no Slackware Linux?

classic Classic list List threaded Threaded
37 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Como Instalar Lua e Löve no Slackware Linux?

Letícia S.
Boa tarde!

Estou tentando instalar o lua no slackware. No terminal, digito

# installpkg lua-5.3.2.tar.gz

Ocorre erro, pois não aceita o formato '.tar.gz', mas aceita o formato '.tgz'.

Fui no site SlackBuilds e encontro o pacote lua no mesmo formato tar.gz:

http://slackbuilds.org/repository/14.1/development/lua/

O mesmo acontece para o pacote löve:

http://slackbuilds.org/repository/14.1/development/love/

Tentei renomar pacote 'tar.gz' para 'tgz'. Não funcionou.

Vocês teriam o pacote lua e löve no formato '.tgz'?


Obrigada 


--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Letícia S.
Quando chegar em casa, vou testar.

:)

Em 15 de janeiro de 2016 12:55, Letícia_user <[hidden email]> escreveu:
Boa tarde!

Estou tentando instalar o lua no slackware. No terminal, digito

# installpkg lua-5.3.2.tar.gz

Ocorre erro, pois não aceita o formato '.tar.gz', mas aceita o formato '.tgz'.

Fui no site SlackBuilds e encontro o pacote lua no mesmo formato tar.gz:

http://slackbuilds.org/repository/14.1/development/lua/

O mesmo acontece para o pacote löve:

http://slackbuilds.org/repository/14.1/development/love/

Tentei renomar pacote 'tar.gz' para 'tgz'. Não funcionou.

Vocês teriam o pacote lua e löve no formato '.tgz'?


Obrigada 


--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Letícia S.
Já tentei fazer o seguinte para instalar o formato .tar.gz:

$ tar -zxvf lua.tar.gz

$ cd nome_do_diretório_criado

$ ./configure

$ make
$ make install


Não deu certo.

Fiz com vários pacotes diferentes de lua. Posso ter cometido algum erro também, não estou acostumada a usar o slackware nem usar esse procedimento mesmo no Ubuntu.




Em 15 de janeiro de 2016 13:06, Letícia S. <[hidden email]> escreveu:
Quando chegar em casa, vou testar.

:)

Em 15 de janeiro de 2016 12:55, Letícia_user <[hidden email]> escreveu:
Boa tarde!

Estou tentando instalar o lua no slackware. No terminal, digito

# installpkg lua-5.3.2.tar.gz

Ocorre erro, pois não aceita o formato '.tar.gz', mas aceita o formato '.tgz'.

Fui no site SlackBuilds e encontro o pacote lua no mesmo formato tar.gz:

http://slackbuilds.org/repository/14.1/development/lua/

O mesmo acontece para o pacote löve:

http://slackbuilds.org/repository/14.1/development/love/

Tentei renomar pacote 'tar.gz' para 'tgz'. Não funcionou.

Vocês teriam o pacote lua e löve no formato '.tgz'?


Obrigada 


--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.


--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Luiz Henrique de Figueiredo
In reply to this post by Letícia S.
> Estou tentando instalar o *lua no slackware*.

Tente

   curl -R -O http://www.lua.org/ftp/lua-5.3.2.tar.gz
   tar zxf lua-5.3.2.tar.gz
   cd lua-5.3.2
   make linux test

como sugerido em http://www.lua.org/start.html

--
Você está recebendo esta mensagem porque se inscreveu no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Visite este grupo em https://groups.google.com/group/lua-br.
Para obter mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Letícia S.
Eu fiz esse procedimento ontem. Fiz em mais de 1 pacote. Não deu certo.

Tentarei novamente.

Em 15 de janeiro de 2016 13:19, Luiz Henrique de Figueiredo <[hidden email]> escreveu:
> Estou tentando instalar o *lua no slackware*.

Tente

   curl -R -O http://www.lua.org/ftp/lua-5.3.2.tar.gz
   tar zxf lua-5.3.2.tar.gz
   cd lua-5.3.2
   make linux test

como sugerido em http://www.lua.org/start.html

--
Você está recebendo esta mensagem porque se inscreveu no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Visite este grupo em https://groups.google.com/group/lua-br.
Para obter mais opções, acesse https://groups.google.com/d/optout.

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Denis Dos Santos Silva
In reply to this post by Letícia S.
bem

no Slack é necessário ter o pacote "D" (que vem as ferramentas de desenvolvimento) no momento da instalação ou posterior.

tar.gz é um arquivo/formato genérico e não necessariamente um 'pacote precompilado' estilo .rpm, .deb, ...

no Slackware usa-se normalmente o pkgtool ( http://www.slackware.com/config/packages.php )

sobre o Love, vou dar uma olhada pois ainda nao usei.

Ah, Leticia cole a mensagem de erro ou mesmo a tela para que possamos achar o que está errado e/ou faltando.




Em sexta-feira, 15 de janeiro de 2016 12:55:45 UTC-2, Letícia_user escreveu:
Boa tarde!

Estou tentando instalar o lua no slackware. No terminal, digito

# installpkg <a href="http://www.lua.org/ftp/lua-5.3.2.tar.gz" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fwww.lua.org%2Fftp%2Flua-5.3.2.tar.gz\46sa\75D\46sntz\0751\46usg\75AFQjCNGshktRAmWyVRxOKk06JZZ1561j8w&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fwww.lua.org%2Fftp%2Flua-5.3.2.tar.gz\46sa\75D\46sntz\0751\46usg\75AFQjCNGshktRAmWyVRxOKk06JZZ1561j8w&#39;;return true;">lua-5.3.2.tar.gz

Ocorre erro, pois não aceita o formato '.tar.gz', mas aceita o formato '.tgz'.

Fui no site SlackBuilds e encontro o pacote lua no mesmo formato tar.gz:

<a href="http://slackbuilds.org/repository/14.1/development/lua/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fslackbuilds.org%2Frepository%2F14.1%2Fdevelopment%2Flua%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNEctvxZQEMWXvitB-Z4K2WsOhkgCw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fslackbuilds.org%2Frepository%2F14.1%2Fdevelopment%2Flua%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNEctvxZQEMWXvitB-Z4K2WsOhkgCw&#39;;return true;">http://slackbuilds.org/repository/14.1/development/lua/

O mesmo acontece para o pacote löve:

<a href="http://slackbuilds.org/repository/14.1/development/love/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fslackbuilds.org%2Frepository%2F14.1%2Fdevelopment%2Flove%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNHTXRzsFaVprcU4ro1_ZXPVumDJTw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fslackbuilds.org%2Frepository%2F14.1%2Fdevelopment%2Flove%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNHTXRzsFaVprcU4ro1_ZXPVumDJTw&#39;;return true;">http://slackbuilds.org/repository/14.1/development/love/

Tentei renomar pacote 'tar.gz' para 'tgz'. Não funcionou.

Vocês teriam o pacote lua e löve no formato '.tgz'?


Obrigada 


--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Letícia S.
Refiz o procedimento que o Luiz indicou:

curl -R -O http://www.lua.org/ftp/lua-5.3.2.tar.gz
   tar zxf lua-5.3.2.tar.gz
   cd lua-5.3.2
   make linux test

No terminal, não reconhe o comando 'curl -R ..'
De todo modo, fiz a sequência 'tar z...' . Não funcionou. Fiz printscreen, as imagens estão em anexo.

No terminal, tem o pkgtool, mas vou ter que aprender a usar.

Obrigada, Denis

Em 15 de janeiro de 2016 18:04, Denis Dos Santos Silva <[hidden email]> escreveu:
bem

no Slack é necessário ter o pacote "D" (que vem as ferramentas de desenvolvimento) no momento da instalação ou posterior.

tar.gz é um arquivo/formato genérico e não necessariamente um 'pacote precompilado' estilo .rpm, .deb, ...

no Slackware usa-se normalmente o pkgtool ( http://www.slackware.com/config/packages.php )

sobre o Love, vou dar uma olhada pois ainda nao usei.

Ah, Leticia cole a mensagem de erro ou mesmo a tela para que possamos achar o que está errado e/ou faltando.




Em sexta-feira, 15 de janeiro de 2016 12:55:45 UTC-2, Letícia_user escreveu:
Boa tarde!

Estou tentando instalar o lua no slackware. No terminal, digito

# installpkg lua-5.3.2.tar.gz

Ocorre erro, pois não aceita o formato '.tar.gz', mas aceita o formato '.tgz'.

Fui no site SlackBuilds e encontro o pacote lua no mesmo formato tar.gz:

http://slackbuilds.org/repository/14.1/development/lua/

O mesmo acontece para o pacote löve:

http://slackbuilds.org/repository/14.1/development/love/

Tentei renomar pacote 'tar.gz' para 'tgz'. Não funcionou.

Vocês teriam o pacote lua e löve no formato '.tgz'?


Obrigada 


--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.

imagem1.png (129K) Download Attachment
imagem2.png (270K) Download Attachment
imagem3.png (208K) Download Attachment
imagem4.png (208K) Download Attachment
imagem5.png (192K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Luiz Henrique de Figueiredo
> No terminal, não reconhe o comando 'curl -R ..'

Tente
        wget http://www.lua.org/ftp/lua-5.3.2.tar.gz

Você precisa instalar o pacote dev de readline.  Veja
        http://www.lua.org/manual/5.3/readme.html

ou então experimente "make posix".

--
Você está recebendo esta mensagem porque se inscreveu no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Visite este grupo em https://groups.google.com/group/lua-br.
Para obter mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Letícia S.
In reply to this post by Letícia S.
Consegui instalar o lua com o pacote formato .tgz:

root@slax:~# installpkg lua-5.1.5-i486-2alien.tgz

Verifying package lua-5.1.5-i486-2alien.tgz.
Installing package lua-5.1.5-i486-2alien.tgz:
PACKAGE DESCRIPTION:
# lua (a powerful, fast, lightweight, embeddable scripting language)
#
# Lua combines simple procedural syntax with powerful data description
# constructs based on associative arrays and extensible semantics.
# Lua is dynamically typed, runs by interpreting bytecode for a
# register-based virtual machine, and has automatic memory management
# with incremental garbage collection, making it ideal for
# configuration, scripting, and rapid prototyping.
#
# lua home: http://www.lua.org/
#
Executing install script for lua-5.1.5-i486-2alien.tgz.
Package lua-5.1.5-i486-2alien.tgz installed.


Para baixar no formato .tgz:

http://www.slackware.com/~alien/slackbuilds/lua/pkg/14.1/

ou

http://www.slackware.com/~alien/slackbuilds/lua/pkg/14.1/lua-5.1.5-i486-2alien.tgz

Com o formato .tgz, é o modo mais fácil. Pretendo aprender as outras maneiras de instalação, a maioria dos pacotes são em tar.gz.

Está faltando o löve, agora.


Em 15 de janeiro de 2016 20:22, Letícia S. <[hidden email]> escreveu:
Refiz o procedimento que o Luiz indicou:

curl -R -O http://www.lua.org/ftp/lua-5.3.2.tar.gz
   tar zxf lua-5.3.2.tar.gz
   cd lua-5.3.2
   make linux test

No terminal, não reconhe o comando 'curl -R ..'
De todo modo, fiz a sequência 'tar z...' . Não funcionou. Fiz printscreen, as imagens estão em anexo.

No terminal, tem o pkgtool, mas vou ter que aprender a usar.

Obrigada, Denis

Em 15 de janeiro de 2016 18:04, Denis Dos Santos Silva <[hidden email]> escreveu:
bem

no Slack é necessário ter o pacote "D" (que vem as ferramentas de desenvolvimento) no momento da instalação ou posterior.

tar.gz é um arquivo/formato genérico e não necessariamente um 'pacote precompilado' estilo .rpm, .deb, ...

no Slackware usa-se normalmente o pkgtool ( http://www.slackware.com/config/packages.php )

sobre o Love, vou dar uma olhada pois ainda nao usei.

Ah, Leticia cole a mensagem de erro ou mesmo a tela para que possamos achar o que está errado e/ou faltando.




Em sexta-feira, 15 de janeiro de 2016 12:55:45 UTC-2, Letícia_user escreveu:
Boa tarde!

Estou tentando instalar o lua no slackware. No terminal, digito

# installpkg lua-5.3.2.tar.gz

Ocorre erro, pois não aceita o formato '.tar.gz', mas aceita o formato '.tgz'.

Fui no site SlackBuilds e encontro o pacote lua no mesmo formato tar.gz:

http://slackbuilds.org/repository/14.1/development/lua/

O mesmo acontece para o pacote löve:

http://slackbuilds.org/repository/14.1/development/love/

Tentei renomar pacote 'tar.gz' para 'tgz'. Não funcionou.

Vocês teriam o pacote lua e löve no formato '.tgz'?


Obrigada 


--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.


--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Letícia S.
In reply to this post by Luiz Henrique de Figueiredo
Obrigada, Luiz. Como estou no Virtualbox, depois tentarei instalar lua com o pacote dev.



Em 15 de janeiro de 2016 20:27, Luiz Henrique de Figueiredo <[hidden email]> escreveu:
> No terminal, não reconhe o comando 'curl -R ..'

Tente
        wget http://www.lua.org/ftp/lua-5.3.2.tar.gz

Você precisa instalar o pacote dev de readline.  Veja
        http://www.lua.org/manual/5.3/readme.html

ou então experimente "make posix".

--
Você está recebendo esta mensagem porque se inscreveu no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Visite este grupo em https://groups.google.com/group/lua-br.
Para obter mais opções, acesse https://groups.google.com/d/optout.

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Denis Dos Santos Silva
In reply to this post by Letícia S.
vamos lá...

aparentemente o love2d usa a versão Lua 5.1 (isso tá https://love2d.org/wiki/Building_L%C3%96VE )

Slackbuild:
Lua 5.1.5 (pré-compilado)  --> http://slackbuilds.org/repository/14.1/development/lua/
Love2D (pré-compilado) --> http://slackbuilds.org/result/?search=love&sv=
OBS: o Love2D depende algumas bibliotecas

---
--- instalando o lua 5.1 do código-fonte
wget http://www.lua.org/ftp/lua-5.1.5.tar.gz
tar zxf lua-5.1.5.tar.gz
cd lua-5.1.5
make generic
make install

---
OBS: make linux (REQUER as bibliotecas (binários+desenvolvedor)  ncurses + readline)

nesse link tem o readline: http://mirrors.slackware.com/slackware/slackware-14.1/slackware/l/

Quais os "packages" que vc instalou ?
o minimo seria o A (base da distro) + AP (alguns aplicativos) + D (desenvolvimento) + N (network/rede) + L (bibliotecas)
isso no modo "FULL" (completo)

sobre as screenshot realmente tá falando a gnu readline...


Em sexta-feira, 15 de janeiro de 2016 12:55:45 UTC-2, Letícia_user escreveu:
Boa tarde!

Estou tentando instalar o lua no slackware. No terminal, digito

# installpkg <a href="http://www.lua.org/ftp/lua-5.3.2.tar.gz" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fwww.lua.org%2Fftp%2Flua-5.3.2.tar.gz\46sa\75D\46sntz\0751\46usg\75AFQjCNGshktRAmWyVRxOKk06JZZ1561j8w&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fwww.lua.org%2Fftp%2Flua-5.3.2.tar.gz\46sa\75D\46sntz\0751\46usg\75AFQjCNGshktRAmWyVRxOKk06JZZ1561j8w&#39;;return true;">lua-5.3.2.tar.gz

Ocorre erro, pois não aceita o formato '.tar.gz', mas aceita o formato '.tgz'.

Fui no site SlackBuilds e encontro o pacote lua no mesmo formato tar.gz:

<a href="http://slackbuilds.org/repository/14.1/development/lua/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fslackbuilds.org%2Frepository%2F14.1%2Fdevelopment%2Flua%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNEctvxZQEMWXvitB-Z4K2WsOhkgCw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fslackbuilds.org%2Frepository%2F14.1%2Fdevelopment%2Flua%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNEctvxZQEMWXvitB-Z4K2WsOhkgCw&#39;;return true;">http://slackbuilds.org/repository/14.1/development/lua/

O mesmo acontece para o pacote löve:

<a href="http://slackbuilds.org/repository/14.1/development/love/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fslackbuilds.org%2Frepository%2F14.1%2Fdevelopment%2Flove%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNHTXRzsFaVprcU4ro1_ZXPVumDJTw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fslackbuilds.org%2Frepository%2F14.1%2Fdevelopment%2Flove%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNHTXRzsFaVprcU4ro1_ZXPVumDJTw&#39;;return true;">http://slackbuilds.org/repository/14.1/development/love/

Tentei renomar pacote 'tar.gz' para 'tgz'. Não funcionou.

Vocês teriam o pacote lua e löve no formato '.tgz'?


Obrigada 


--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Letícia S.
Denis, a instalação do lua deu certo, seguindo esses comandos:

tar zxf lua-5.1.5.tar.gz
cd lua-5.1.5
make generic
make install

Estão, em anexo, as imagens.

Eu consegui instalar antes com pacote lua-5.1....tgz . Esse pacote está anexado também:

http://www.slackware.com/~alien/slackbuilds/lua/pkg/14.1/

Agora, falta instalar as bibliotecas para o love2D.

:)





Em 15 de janeiro de 2016 22:16, Denis Dos Santos Silva <[hidden email]> escreveu:
vamos lá...

aparentemente o love2d usa a versão Lua 5.1 (isso tá https://love2d.org/wiki/Building_L%C3%96VE )

Slackbuild:
OBS: o Love2D depende algumas bibliotecas

---
--- instalando o lua 5.1 do código-fonte
tar zxf lua-5.1.5.tar.gz
cd lua-5.1.5
make generic
make install

---
OBS: make linux (REQUER as bibliotecas (binários+desenvolvedor)  ncurses + readline)


Quais os "packages" que vc instalou ?
o minimo seria o A (base da distro) + AP (alguns aplicativos) + D (desenvolvimento) + N (network/rede) + L (bibliotecas)
isso no modo "FULL" (completo)

sobre as screenshot realmente tá falando a gnu readline...


Em sexta-feira, 15 de janeiro de 2016 12:55:45 UTC-2, Letícia_user escreveu:
Boa tarde!

Estou tentando instalar o lua no slackware. No terminal, digito

# installpkg lua-5.3.2.tar.gz

Ocorre erro, pois não aceita o formato '.tar.gz', mas aceita o formato '.tgz'.

Fui no site SlackBuilds e encontro o pacote lua no mesmo formato tar.gz:

http://slackbuilds.org/repository/14.1/development/lua/

O mesmo acontece para o pacote löve:

http://slackbuilds.org/repository/14.1/development/love/

Tentei renomar pacote 'tar.gz' para 'tgz'. Não funcionou.

Vocês teriam o pacote lua e löve no formato '.tgz'?


Obrigada 


--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.

imagem1.png (194K) Download Attachment
imagem2.png (182K) Download Attachment
imagem3.png (180K) Download Attachment
lua-5.1.5-i486-2alien.tgz (553K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Denis Dos Santos Silva
In reply to this post by Letícia S.
bacana.

vc ta usando qual versao do slack ?



Em sexta-feira, 15 de janeiro de 2016 12:55:45 UTC-2, Letícia_user escreveu:
Boa tarde!

Estou tentando instalar o lua no slackware. No terminal, digito

# installpkg <a href="http://www.lua.org/ftp/lua-5.3.2.tar.gz" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fwww.lua.org%2Fftp%2Flua-5.3.2.tar.gz\46sa\75D\46sntz\0751\46usg\75AFQjCNGshktRAmWyVRxOKk06JZZ1561j8w&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fwww.lua.org%2Fftp%2Flua-5.3.2.tar.gz\46sa\75D\46sntz\0751\46usg\75AFQjCNGshktRAmWyVRxOKk06JZZ1561j8w&#39;;return true;">lua-5.3.2.tar.gz

Ocorre erro, pois não aceita o formato '.tar.gz', mas aceita o formato '.tgz'.

Fui no site SlackBuilds e encontro o pacote lua no mesmo formato tar.gz:

<a href="http://slackbuilds.org/repository/14.1/development/lua/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fslackbuilds.org%2Frepository%2F14.1%2Fdevelopment%2Flua%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNEctvxZQEMWXvitB-Z4K2WsOhkgCw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fslackbuilds.org%2Frepository%2F14.1%2Fdevelopment%2Flua%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNEctvxZQEMWXvitB-Z4K2WsOhkgCw&#39;;return true;">http://slackbuilds.org/repository/14.1/development/lua/

O mesmo acontece para o pacote löve:

<a href="http://slackbuilds.org/repository/14.1/development/love/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fslackbuilds.org%2Frepository%2F14.1%2Fdevelopment%2Flove%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNHTXRzsFaVprcU4ro1_ZXPVumDJTw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\75http%3A%2F%2Fslackbuilds.org%2Frepository%2F14.1%2Fdevelopment%2Flove%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNHTXRzsFaVprcU4ro1_ZXPVumDJTw&#39;;return true;">http://slackbuilds.org/repository/14.1/development/love/

Tentei renomar pacote 'tar.gz' para 'tgz'. Não funcionou.

Vocês teriam o pacote lua e löve no formato '.tgz'?


Obrigada 


--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Letícia S.
Estou usando o Slax linux, baseado no Slackware.

Estou avaliando esse linux, porque estou tendo problemas no meu computador com as versões Ubuntus (Xubuntu, Mint, Lubuntu, Bodhi) e debian. Esses sistemas travam. Busco por um linux leve:

http://pplware.sapo.pt/linux/chegou-o-linux-slax-7-green-horn-com-apenas-210-mb/

Minha placa mãe é Nvidia. Para manter ubuntu ou debian, tenho que instalar os drivers. Mas quando instalo, não funciona o love2D. Quando desistalo os drives, funciona love2D, mas o computador, mais cedo ou mais tarde, trava.

O que menos trava é o lubuntu.

Estou gostando do slax, embora esteja testando no virtualbox (pode ser que ao instalá-lo, também trave...). No momento, estou aprendendo a usar o slax.

Consegui instalar algumas bibliotecas, outras não, porque o modo de instalar é diferente dessa sequência padrão:

1) wget pacote.tar.gz
2) tar zxf pacote.tar.gz
3) cd pacote
4) ./configure
5) make
6) make install

Quando é possível realizar essa sequência, instalo sem problemas. Mas quando não tem o item "configure", começam as dificuldades.



Em 16 de janeiro de 2016 00:52, Denis Dos Santos Silva <[hidden email]> escreveu:
bacana.

vc ta usando qual versao do slack ?



Em sexta-feira, 15 de janeiro de 2016 12:55:45 UTC-2, Letícia_user escreveu:
Boa tarde!

Estou tentando instalar o lua no slackware. No terminal, digito

# installpkg lua-5.3.2.tar.gz

Ocorre erro, pois não aceita o formato '.tar.gz', mas aceita o formato '.tgz'.

Fui no site SlackBuilds e encontro o pacote lua no mesmo formato tar.gz:

http://slackbuilds.org/repository/14.1/development/lua/

O mesmo acontece para o pacote löve:

http://slackbuilds.org/repository/14.1/development/love/

Tentei renomar pacote 'tar.gz' para 'tgz'. Não funcionou.

Vocês teriam o pacote lua e löve no formato '.tgz'?


Obrigada 


--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Letícia S.
A minha versão é Slax 7.0.8

http://www.slax.org/download.php

Em 16 de janeiro de 2016 11:47, Letícia S. <[hidden email]> escreveu:
Estou usando o Slax linux, baseado no Slackware.

Estou avaliando esse linux, porque estou tendo problemas no meu computador com as versões Ubuntus (Xubuntu, Mint, Lubuntu, Bodhi) e debian. Esses sistemas travam. Busco por um linux leve:

http://pplware.sapo.pt/linux/chegou-o-linux-slax-7-green-horn-com-apenas-210-mb/

Minha placa mãe é Nvidia. Para manter ubuntu ou debian, tenho que instalar os drivers. Mas quando instalo, não funciona o love2D. Quando desistalo os drives, funciona love2D, mas o computador, mais cedo ou mais tarde, trava.

O que menos trava é o lubuntu.

Estou gostando do slax, embora esteja testando no virtualbox (pode ser que ao instalá-lo, também trave...). No momento, estou aprendendo a usar o slax.

Consegui instalar algumas bibliotecas, outras não, porque o modo de instalar é diferente dessa sequência padrão:

1) wget pacote.tar.gz
2) tar zxf pacote.tar.gz
3) cd pacote
4) ./configure
5) make
6) make install

Quando é possível realizar essa sequência, instalo sem problemas. Mas quando não tem o item "configure", começam as dificuldades.



Em 16 de janeiro de 2016 00:52, Denis Dos Santos Silva <[hidden email]> escreveu:
bacana.

vc ta usando qual versao do slack ?



Em sexta-feira, 15 de janeiro de 2016 12:55:45 UTC-2, Letícia_user escreveu:
Boa tarde!

Estou tentando instalar o lua no slackware. No terminal, digito

# installpkg lua-5.3.2.tar.gz

Ocorre erro, pois não aceita o formato '.tar.gz', mas aceita o formato '.tgz'.

Fui no site SlackBuilds e encontro o pacote lua no mesmo formato tar.gz:

http://slackbuilds.org/repository/14.1/development/lua/

O mesmo acontece para o pacote löve:

http://slackbuilds.org/repository/14.1/development/love/

Tentei renomar pacote 'tar.gz' para 'tgz'. Não funcionou.

Vocês teriam o pacote lua e löve no formato '.tgz'?


Obrigada 


--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.


--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Diego Nascimento
Leticia, não consegue instalar o love, é isso, precisa complicar no slax?

Em 16 de janeiro de 2016 11:48, Letícia S.
<[hidden email]> escreveu:

> A minha versão é Slax 7.0.8
>
> http://www.slax.org/download.php
>
> Em 16 de janeiro de 2016 11:47, Letícia S. <[hidden email]>
> escreveu:
>>
>> Estou usando o Slax linux, baseado no Slackware.
>>
>> Estou avaliando esse linux, porque estou tendo problemas no meu computador
>> com as versões Ubuntus (Xubuntu, Mint, Lubuntu, Bodhi) e debian. Esses
>> sistemas travam. Busco por um linux leve:
>>
>>
>> http://pplware.sapo.pt/linux/chegou-o-linux-slax-7-green-horn-com-apenas-210-mb/
>>
>> Minha placa mãe é Nvidia. Para manter ubuntu ou debian, tenho que instalar
>> os drivers. Mas quando instalo, não funciona o love2D. Quando desistalo os
>> drives, funciona love2D, mas o computador, mais cedo ou mais tarde, trava.
>>
>> O que menos trava é o lubuntu.
>>
>> Estou gostando do slax, embora esteja testando no virtualbox (pode ser que
>> ao instalá-lo, também trave...). No momento, estou aprendendo a usar o slax.
>>
>> Consegui instalar algumas bibliotecas, outras não, porque o modo de
>> instalar é diferente dessa sequência padrão:
>>
>> 1) wget pacote.tar.gz
>> 2) tar zxf pacote.tar.gz
>> 3) cd pacote
>> 4) ./configure
>> 5) make
>> 6) make install
>>
>> Quando é possível realizar essa sequência, instalo sem problemas. Mas
>> quando não tem o item "configure", começam as dificuldades.
>>
>>
>>
>> Em 16 de janeiro de 2016 00:52, Denis Dos Santos Silva <[hidden email]>
>> escreveu:
>>>
>>> bacana.
>>>
>>> vc ta usando qual versao do slack ?
>>>
>>>
>>>
>>> Em sexta-feira, 15 de janeiro de 2016 12:55:45 UTC-2, Letícia_user
>>> escreveu:
>>>>
>>>> Boa tarde!
>>>>
>>>> Estou tentando instalar o lua no slackware. No terminal, digito
>>>>
>>>> # installpkg lua-5.3.2.tar.gz
>>>>
>>>> Ocorre erro, pois não aceita o formato '.tar.gz', mas aceita o formato
>>>> '.tgz'.
>>>>
>>>> Fui no site SlackBuilds e encontro o pacote lua no mesmo formato tar.gz:
>>>>
>>>> http://slackbuilds.org/repository/14.1/development/lua/
>>>>
>>>> O mesmo acontece para o pacote löve:
>>>>
>>>> http://slackbuilds.org/repository/14.1/development/love/
>>>>
>>>> Tentei renomar pacote 'tar.gz' para 'tgz'. Não funcionou.
>>>>
>>>> Vocês teriam o pacote lua e löve no formato '.tgz'?
>>>>
>>>>
>>>> Obrigada
>>>>
>>>>
>>> --
>>> Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos
>>> Grupos do Google.
>>> Para cancelar inscrição nesse grupo e parar de receber e-mails dele,
>>> envie um e-mail para [hidden email].
>>> Acesse esse grupo em https://groups.google.com/group/lua-br.
>>> Para mais opções, acesse https://groups.google.com/d/optout.
>>
>>
>
> --
> Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos
> do Google.
> Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie
> um e-mail para [hidden email].
> Acesse esse grupo em https://groups.google.com/group/lua-br.
> Para mais opções, acesse https://groups.google.com/d/optout.

--
Você está recebendo esta mensagem porque se inscreveu no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Visite este grupo em https://groups.google.com/group/lua-br.
Para obter mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Diego Nascimento
ops, compilar.

Em 16 de janeiro de 2016 12:07, Diego Nascimento <[hidden email]> escreveu:

> Leticia, não consegue instalar o love, é isso, precisa complicar no slax?
>
> Em 16 de janeiro de 2016 11:48, Letícia S.
> <[hidden email]> escreveu:
>> A minha versão é Slax 7.0.8
>>
>> http://www.slax.org/download.php
>>
>> Em 16 de janeiro de 2016 11:47, Letícia S. <[hidden email]>
>> escreveu:
>>>
>>> Estou usando o Slax linux, baseado no Slackware.
>>>
>>> Estou avaliando esse linux, porque estou tendo problemas no meu computador
>>> com as versões Ubuntus (Xubuntu, Mint, Lubuntu, Bodhi) e debian. Esses
>>> sistemas travam. Busco por um linux leve:
>>>
>>>
>>> http://pplware.sapo.pt/linux/chegou-o-linux-slax-7-green-horn-com-apenas-210-mb/
>>>
>>> Minha placa mãe é Nvidia. Para manter ubuntu ou debian, tenho que instalar
>>> os drivers. Mas quando instalo, não funciona o love2D. Quando desistalo os
>>> drives, funciona love2D, mas o computador, mais cedo ou mais tarde, trava.
>>>
>>> O que menos trava é o lubuntu.
>>>
>>> Estou gostando do slax, embora esteja testando no virtualbox (pode ser que
>>> ao instalá-lo, também trave...). No momento, estou aprendendo a usar o slax.
>>>
>>> Consegui instalar algumas bibliotecas, outras não, porque o modo de
>>> instalar é diferente dessa sequência padrão:
>>>
>>> 1) wget pacote.tar.gz
>>> 2) tar zxf pacote.tar.gz
>>> 3) cd pacote
>>> 4) ./configure
>>> 5) make
>>> 6) make install
>>>
>>> Quando é possível realizar essa sequência, instalo sem problemas. Mas
>>> quando não tem o item "configure", começam as dificuldades.
>>>
>>>
>>>
>>> Em 16 de janeiro de 2016 00:52, Denis Dos Santos Silva <[hidden email]>
>>> escreveu:
>>>>
>>>> bacana.
>>>>
>>>> vc ta usando qual versao do slack ?
>>>>
>>>>
>>>>
>>>> Em sexta-feira, 15 de janeiro de 2016 12:55:45 UTC-2, Letícia_user
>>>> escreveu:
>>>>>
>>>>> Boa tarde!
>>>>>
>>>>> Estou tentando instalar o lua no slackware. No terminal, digito
>>>>>
>>>>> # installpkg lua-5.3.2.tar.gz
>>>>>
>>>>> Ocorre erro, pois não aceita o formato '.tar.gz', mas aceita o formato
>>>>> '.tgz'.
>>>>>
>>>>> Fui no site SlackBuilds e encontro o pacote lua no mesmo formato tar.gz:
>>>>>
>>>>> http://slackbuilds.org/repository/14.1/development/lua/
>>>>>
>>>>> O mesmo acontece para o pacote löve:
>>>>>
>>>>> http://slackbuilds.org/repository/14.1/development/love/
>>>>>
>>>>> Tentei renomar pacote 'tar.gz' para 'tgz'. Não funcionou.
>>>>>
>>>>> Vocês teriam o pacote lua e löve no formato '.tgz'?
>>>>>
>>>>>
>>>>> Obrigada
>>>>>
>>>>>
>>>> --
>>>> Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos
>>>> Grupos do Google.
>>>> Para cancelar inscrição nesse grupo e parar de receber e-mails dele,
>>>> envie um e-mail para [hidden email].
>>>> Acesse esse grupo em https://groups.google.com/group/lua-br.
>>>> Para mais opções, acesse https://groups.google.com/d/optout.
>>>
>>>
>>
>> --
>> Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos
>> do Google.
>> Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie
>> um e-mail para [hidden email].
>> Acesse esse grupo em https://groups.google.com/group/lua-br.
>> Para mais opções, acesse https://groups.google.com/d/optout.

--
Você está recebendo esta mensagem porque se inscreveu no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Visite este grupo em https://groups.google.com/group/lua-br.
Para obter mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Letícia S.
Sim, agora, só está faltando instalar o love2D e os requisistos (as bibliotecas).



Em 16 de janeiro de 2016 12:08, Diego Nascimento <[hidden email]> escreveu:
ops, compilar.

Em 16 de janeiro de 2016 12:07, Diego Nascimento <[hidden email]> escreveu:
> Leticia, não consegue instalar o love, é isso, precisa complicar no slax?
>
> Em 16 de janeiro de 2016 11:48, Letícia S.
> <[hidden email]> escreveu:
>> A minha versão é Slax 7.0.8
>>
>> http://www.slax.org/download.php
>>
>> Em 16 de janeiro de 2016 11:47, Letícia S. <[hidden email]>
>> escreveu:
>>>
>>> Estou usando o Slax linux, baseado no Slackware.
>>>
>>> Estou avaliando esse linux, porque estou tendo problemas no meu computador
>>> com as versões Ubuntus (Xubuntu, Mint, Lubuntu, Bodhi) e debian. Esses
>>> sistemas travam. Busco por um linux leve:
>>>
>>>
>>> http://pplware.sapo.pt/linux/chegou-o-linux-slax-7-green-horn-com-apenas-210-mb/
>>>
>>> Minha placa mãe é Nvidia. Para manter ubuntu ou debian, tenho que instalar
>>> os drivers. Mas quando instalo, não funciona o love2D. Quando desistalo os
>>> drives, funciona love2D, mas o computador, mais cedo ou mais tarde, trava.
>>>
>>> O que menos trava é o lubuntu.
>>>
>>> Estou gostando do slax, embora esteja testando no virtualbox (pode ser que
>>> ao instalá-lo, também trave...). No momento, estou aprendendo a usar o slax.
>>>
>>> Consegui instalar algumas bibliotecas, outras não, porque o modo de
>>> instalar é diferente dessa sequência padrão:
>>>
>>> 1) wget pacote.tar.gz
>>> 2) tar zxf pacote.tar.gz
>>> 3) cd pacote
>>> 4) ./configure
>>> 5) make
>>> 6) make install
>>>
>>> Quando é possível realizar essa sequência, instalo sem problemas. Mas
>>> quando não tem o item "configure", começam as dificuldades.
>>>
>>>
>>>
>>> Em 16 de janeiro de 2016 00:52, Denis Dos Santos Silva <[hidden email]>
>>> escreveu:
>>>>
>>>> bacana.
>>>>
>>>> vc ta usando qual versao do slack ?
>>>>
>>>>
>>>>
>>>> Em sexta-feira, 15 de janeiro de 2016 12:55:45 UTC-2, Letícia_user
>>>> escreveu:
>>>>>
>>>>> Boa tarde!
>>>>>
>>>>> Estou tentando instalar o lua no slackware. No terminal, digito
>>>>>
>>>>> # installpkg lua-5.3.2.tar.gz
>>>>>
>>>>> Ocorre erro, pois não aceita o formato '.tar.gz', mas aceita o formato
>>>>> '.tgz'.
>>>>>
>>>>> Fui no site SlackBuilds e encontro o pacote lua no mesmo formato tar.gz:
>>>>>
>>>>> http://slackbuilds.org/repository/14.1/development/lua/
>>>>>
>>>>> O mesmo acontece para o pacote löve:
>>>>>
>>>>> http://slackbuilds.org/repository/14.1/development/love/
>>>>>
>>>>> Tentei renomar pacote 'tar.gz' para 'tgz'. Não funcionou.
>>>>>
>>>>> Vocês teriam o pacote lua e löve no formato '.tgz'?
>>>>>
>>>>>
>>>>> Obrigada
>>>>>
>>>>>
>>>> --
>>>> Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos
>>>> Grupos do Google.
>>>> Para cancelar inscrição nesse grupo e parar de receber e-mails dele,
>>>> envie um e-mail para [hidden email].
>>>> Acesse esse grupo em https://groups.google.com/group/lua-br.
>>>> Para mais opções, acesse https://groups.google.com/d/optout.
>>>
>>>
>>
>> --
>> Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos
>> do Google.
>> Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie
>> um e-mail para [hidden email].
>> Acesse esse grupo em https://groups.google.com/group/lua-br.
>> Para mais opções, acesse https://groups.google.com/d/optout.

--
Você está recebendo esta mensagem porque se inscreveu no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Visite este grupo em https://groups.google.com/group/lua-br.
Para obter mais opções, acesse https://groups.google.com/d/optout.

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Diego Nascimento
In reply to this post by Diego Nascimento
tem um slackbuild da versão 0.9.2
http://slackbuilds.org/repository/14.1/development/love/
http://packages.slackonly.com/pub/packages/14.1-x86_64/development/love/

Em 16 de janeiro de 2016 12:08, Diego Nascimento <[hidden email]> escreveu:

> ops, compilar.
>
> Em 16 de janeiro de 2016 12:07, Diego Nascimento <[hidden email]> escreveu:
>> Leticia, não consegue instalar o love, é isso, precisa complicar no slax?
>>
>> Em 16 de janeiro de 2016 11:48, Letícia S.
>> <[hidden email]> escreveu:
>>> A minha versão é Slax 7.0.8
>>>
>>> http://www.slax.org/download.php
>>>
>>> Em 16 de janeiro de 2016 11:47, Letícia S. <[hidden email]>
>>> escreveu:
>>>>
>>>> Estou usando o Slax linux, baseado no Slackware.
>>>>
>>>> Estou avaliando esse linux, porque estou tendo problemas no meu computador
>>>> com as versões Ubuntus (Xubuntu, Mint, Lubuntu, Bodhi) e debian. Esses
>>>> sistemas travam. Busco por um linux leve:
>>>>
>>>>
>>>> http://pplware.sapo.pt/linux/chegou-o-linux-slax-7-green-horn-com-apenas-210-mb/
>>>>
>>>> Minha placa mãe é Nvidia. Para manter ubuntu ou debian, tenho que instalar
>>>> os drivers. Mas quando instalo, não funciona o love2D. Quando desistalo os
>>>> drives, funciona love2D, mas o computador, mais cedo ou mais tarde, trava.
>>>>
>>>> O que menos trava é o lubuntu.
>>>>
>>>> Estou gostando do slax, embora esteja testando no virtualbox (pode ser que
>>>> ao instalá-lo, também trave...). No momento, estou aprendendo a usar o slax.
>>>>
>>>> Consegui instalar algumas bibliotecas, outras não, porque o modo de
>>>> instalar é diferente dessa sequência padrão:
>>>>
>>>> 1) wget pacote.tar.gz
>>>> 2) tar zxf pacote.tar.gz
>>>> 3) cd pacote
>>>> 4) ./configure
>>>> 5) make
>>>> 6) make install
>>>>
>>>> Quando é possível realizar essa sequência, instalo sem problemas. Mas
>>>> quando não tem o item "configure", começam as dificuldades.
>>>>
>>>>
>>>>
>>>> Em 16 de janeiro de 2016 00:52, Denis Dos Santos Silva <[hidden email]>
>>>> escreveu:
>>>>>
>>>>> bacana.
>>>>>
>>>>> vc ta usando qual versao do slack ?
>>>>>
>>>>>
>>>>>
>>>>> Em sexta-feira, 15 de janeiro de 2016 12:55:45 UTC-2, Letícia_user
>>>>> escreveu:
>>>>>>
>>>>>> Boa tarde!
>>>>>>
>>>>>> Estou tentando instalar o lua no slackware. No terminal, digito
>>>>>>
>>>>>> # installpkg lua-5.3.2.tar.gz
>>>>>>
>>>>>> Ocorre erro, pois não aceita o formato '.tar.gz', mas aceita o formato
>>>>>> '.tgz'.
>>>>>>
>>>>>> Fui no site SlackBuilds e encontro o pacote lua no mesmo formato tar.gz:
>>>>>>
>>>>>> http://slackbuilds.org/repository/14.1/development/lua/
>>>>>>
>>>>>> O mesmo acontece para o pacote löve:
>>>>>>
>>>>>> http://slackbuilds.org/repository/14.1/development/love/
>>>>>>
>>>>>> Tentei renomar pacote 'tar.gz' para 'tgz'. Não funcionou.
>>>>>>
>>>>>> Vocês teriam o pacote lua e löve no formato '.tgz'?
>>>>>>
>>>>>>
>>>>>> Obrigada
>>>>>>
>>>>>>
>>>>> --
>>>>> Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos
>>>>> Grupos do Google.
>>>>> Para cancelar inscrição nesse grupo e parar de receber e-mails dele,
>>>>> envie um e-mail para [hidden email].
>>>>> Acesse esse grupo em https://groups.google.com/group/lua-br.
>>>>> Para mais opções, acesse https://groups.google.com/d/optout.
>>>>
>>>>
>>>
>>> --
>>> Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos
>>> do Google.
>>> Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie
>>> um e-mail para [hidden email].
>>> Acesse esse grupo em https://groups.google.com/group/lua-br.
>>> Para mais opções, acesse https://groups.google.com/d/optout.

--
Você está recebendo esta mensagem porque se inscreveu no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Visite este grupo em https://groups.google.com/group/lua-br.
Para obter mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Como Instalar Lua e Löve no Slackware Linux?

Diego Nascimento
PACKAGE REQUIRED:  SDL2,luajit,DevIL,OpenAL,libmodplug,physfs

Em 16 de janeiro de 2016 12:21, Diego Nascimento <[hidden email]> escreveu:

> tem um slackbuild da versão 0.9.2
> http://slackbuilds.org/repository/14.1/development/love/
> http://packages.slackonly.com/pub/packages/14.1-x86_64/development/love/
>
> Em 16 de janeiro de 2016 12:08, Diego Nascimento <[hidden email]> escreveu:
>> ops, compilar.
>>
>> Em 16 de janeiro de 2016 12:07, Diego Nascimento <[hidden email]> escreveu:
>>> Leticia, não consegue instalar o love, é isso, precisa complicar no slax?
>>>
>>> Em 16 de janeiro de 2016 11:48, Letícia S.
>>> <[hidden email]> escreveu:
>>>> A minha versão é Slax 7.0.8
>>>>
>>>> http://www.slax.org/download.php
>>>>
>>>> Em 16 de janeiro de 2016 11:47, Letícia S. <[hidden email]>
>>>> escreveu:
>>>>>
>>>>> Estou usando o Slax linux, baseado no Slackware.
>>>>>
>>>>> Estou avaliando esse linux, porque estou tendo problemas no meu computador
>>>>> com as versões Ubuntus (Xubuntu, Mint, Lubuntu, Bodhi) e debian. Esses
>>>>> sistemas travam. Busco por um linux leve:
>>>>>
>>>>>
>>>>> http://pplware.sapo.pt/linux/chegou-o-linux-slax-7-green-horn-com-apenas-210-mb/
>>>>>
>>>>> Minha placa mãe é Nvidia. Para manter ubuntu ou debian, tenho que instalar
>>>>> os drivers. Mas quando instalo, não funciona o love2D. Quando desistalo os
>>>>> drives, funciona love2D, mas o computador, mais cedo ou mais tarde, trava.
>>>>>
>>>>> O que menos trava é o lubuntu.
>>>>>
>>>>> Estou gostando do slax, embora esteja testando no virtualbox (pode ser que
>>>>> ao instalá-lo, também trave...). No momento, estou aprendendo a usar o slax.
>>>>>
>>>>> Consegui instalar algumas bibliotecas, outras não, porque o modo de
>>>>> instalar é diferente dessa sequência padrão:
>>>>>
>>>>> 1) wget pacote.tar.gz
>>>>> 2) tar zxf pacote.tar.gz
>>>>> 3) cd pacote
>>>>> 4) ./configure
>>>>> 5) make
>>>>> 6) make install
>>>>>
>>>>> Quando é possível realizar essa sequência, instalo sem problemas. Mas
>>>>> quando não tem o item "configure", começam as dificuldades.
>>>>>
>>>>>
>>>>>
>>>>> Em 16 de janeiro de 2016 00:52, Denis Dos Santos Silva <[hidden email]>
>>>>> escreveu:
>>>>>>
>>>>>> bacana.
>>>>>>
>>>>>> vc ta usando qual versao do slack ?
>>>>>>
>>>>>>
>>>>>>
>>>>>> Em sexta-feira, 15 de janeiro de 2016 12:55:45 UTC-2, Letícia_user
>>>>>> escreveu:
>>>>>>>
>>>>>>> Boa tarde!
>>>>>>>
>>>>>>> Estou tentando instalar o lua no slackware. No terminal, digito
>>>>>>>
>>>>>>> # installpkg lua-5.3.2.tar.gz
>>>>>>>
>>>>>>> Ocorre erro, pois não aceita o formato '.tar.gz', mas aceita o formato
>>>>>>> '.tgz'.
>>>>>>>
>>>>>>> Fui no site SlackBuilds e encontro o pacote lua no mesmo formato tar.gz:
>>>>>>>
>>>>>>> http://slackbuilds.org/repository/14.1/development/lua/
>>>>>>>
>>>>>>> O mesmo acontece para o pacote löve:
>>>>>>>
>>>>>>> http://slackbuilds.org/repository/14.1/development/love/
>>>>>>>
>>>>>>> Tentei renomar pacote 'tar.gz' para 'tgz'. Não funcionou.
>>>>>>>
>>>>>>> Vocês teriam o pacote lua e löve no formato '.tgz'?
>>>>>>>
>>>>>>>
>>>>>>> Obrigada
>>>>>>>
>>>>>>>
>>>>>> --
>>>>>> Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos
>>>>>> Grupos do Google.
>>>>>> Para cancelar inscrição nesse grupo e parar de receber e-mails dele,
>>>>>> envie um e-mail para [hidden email].
>>>>>> Acesse esse grupo em https://groups.google.com/group/lua-br.
>>>>>> Para mais opções, acesse https://groups.google.com/d/optout.
>>>>>
>>>>>
>>>>
>>>> --
>>>> Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos
>>>> do Google.
>>>> Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie
>>>> um e-mail para [hidden email].
>>>> Acesse esse grupo em https://groups.google.com/group/lua-br.
>>>> Para mais opções, acesse https://groups.google.com/d/optout.

--
Você está recebendo esta mensagem porque se inscreveu no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Visite este grupo em https://groups.google.com/group/lua-br.
Para obter mais opções, acesse https://groups.google.com/d/optout.
12