Building LuaRocks Binary for Windows?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Building LuaRocks Binary for Windows?

Russell Haley
Hi,

Title says it all. I tried building LuaRocks in msys2 with mingw but got a weird error (I also get a similar error when running Luarocks from IN msys2):

russh@LAYNE MINGW64 /c/Users/russh/git/luarocks
$ make binary
(unset ; \
"/usr/local/bin/lua" binary/all_in_one "src/bin/luarocks" "/usr/local" "^src/luarocks/admin/" "/usr/local/etc/luarocks" "build-binary" "" unix cc  )
/usr/local/bin/lua: ./src/luarocks/fs/tools.lua:54: 'popen' not supported
stack traceback:
        [C]: in function 'io.popen'
        ./src/luarocks/fs/tools.lua:54: in function 'luarocks.fs.current_dir'
        ./src/luarocks/fs/tools.lua:105: in function 'luarocks.fs.execute_string'
        (...tail calls...)
        ./src/luarocks/fs/unix/tools.lua:26: in function 'luarocks.fs.make_dir'
        binary/all_in_one:444: in local 'main'
        binary/all_in_one:486: in main chunk
        [C]: in ?
make: *** [GNUmakefile:95: build-binary/luarocks.exe] Error 1

For a second attempt I installed mingw-w64 on a recent debian VM (pureos) but I don't know how to configure luarocks to target Windows on Linux?

I tried `nmake binary` but it just says the target is up to date.

Does anyone have any hints? I'd love an rtfm link?

Regards,
Russell