Autocomplete dinâmico Lua

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Autocomplete dinâmico Lua

Lucius Matos
Olá!

Estou tentando usar autocomplete em tabelas, porém tanto o SciTE (1.75) (fonte: https://github.com/rjpcomputing/luaforwindows , clone zip)como o ZeroBrain(1.8, fonte: https://github.com/pkulchenko/ZeroBraneStudio clone zip) não apresentam este recurso nativamente.

Exemplo:

pessoa={}
pessoa.nome="eu"
pessoa.peso=100

--Ao digitar "pe" o auticomple exibe "pessoa"
-- Porém, ao completar a palavra e dar um "." (ponto) não é exibido um menu suspenso com com campos "nome" e "peso".
pessoa.

O que eu devo fazer para configurar os IDE's para corrigir isso.

Observação: Localizei "https://www.autohotkey.com/boards/viewtopic.php?t=14217" mas não consigo achar o diretório para fazer a alteração.
Quanto ao ZeroBrain não encontrei nada útil.

Desde já grato pela ajuda!


--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Autocomplete dinâmico Lua

Mauricio Henrique Bomfim
Lucius,

se trocar de IDE não for um problema, o autocomplete de Lua funciona no Visual Studio Code com a extensão vscode-lua instalada.

[]s

Mauricio


On Sun, Mar 24, 2019 at 12:50 PM Lucius Matos <[hidden email]> wrote:
Olá!

Estou tentando usar autocomplete em tabelas, porém tanto o SciTE (1.75) (fonte: https://github.com/rjpcomputing/luaforwindows , clone zip)como o ZeroBrain(1.8, fonte: https://github.com/pkulchenko/ZeroBraneStudio clone zip) não apresentam este recurso nativamente.

Exemplo:

pessoa={}
pessoa.nome="eu"
pessoa.peso=100

--Ao digitar "pe" o auticomple exibe "pessoa"
-- Porém, ao completar a palavra e dar um "." (ponto) não é exibido um menu suspenso com com campos "nome" e "peso".
pessoa.

O que eu devo fazer para configurar os IDE's para corrigir isso.

Observação: Localizei "https://www.autohotkey.com/boards/viewtopic.php?t=14217" mas não consigo achar o diretório para fazer a alteração.
Quanto ao ZeroBrain não encontrei nada útil.

Desde já grato pela ajuda!


--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Autocomplete dinâmico Lua

Lucius Matos
Obrigado!

Ainda assim, gostaria de usar o ZeroBrain pelo conjunto de funcionalidades. Estes IDE's tem autocomplete mais não para membros do tipo tabela.

Em dom, 24 de mar de 2019 às 13:08, Mauricio Henrique Bomfim <[hidden email]> escreveu:
Lucius,

se trocar de IDE não for um problema, o autocomplete de Lua funciona no Visual Studio Code com a extensão vscode-lua instalada.

[]s

Mauricio


On Sun, Mar 24, 2019 at 12:50 PM Lucius Matos <[hidden email]> wrote:
Olá!

Estou tentando usar autocomplete em tabelas, porém tanto o SciTE (1.75) (fonte: https://github.com/rjpcomputing/luaforwindows , clone zip)como o ZeroBrain(1.8, fonte: https://github.com/pkulchenko/ZeroBraneStudio clone zip) não apresentam este recurso nativamente.

Exemplo:

pessoa={}
pessoa.nome="eu"
pessoa.peso=100

--Ao digitar "pe" o auticomple exibe "pessoa"
-- Porém, ao completar a palavra e dar um "." (ponto) não é exibido um menu suspenso com com campos "nome" e "peso".
pessoa.

O que eu devo fazer para configurar os IDE's para corrigir isso.

Observação: Localizei "https://www.autohotkey.com/boards/viewtopic.php?t=14217" mas não consigo achar o diretório para fazer a alteração.
Quanto ao ZeroBrain não encontrei nada útil.

Desde já grato pela ajuda!


--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.

--
Você recebeu essa mensagem porque está inscrito no grupo "Lua BR" dos Grupos do Google.
Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para [hidden email].
Acesse esse grupo em https://groups.google.com/group/lua-br.
Para mais opções, acesse https://groups.google.com/d/optout.