[ANN] luaposix 34.1 released

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[ANN] luaposix 34.1 released

Gary V. Vaughan
A library binding various POSIX APIs. POSIX is the IEEE Portable
Operating System Interface standard. luaposix is based on lposix.

I am happy to announce release 34.1 of luaposix.

If you have moved to the new low-level APIs, and don't rely on the Lua
backwards compatibility layer and convenience functions, you can safely
omit those dependencies and use the C layer only.

luaposix's home page is at https://github.com/luaposix/luaposix/, with
documentation at https://luaposix.github.io/luaposix.


## Noteworthy changes in release 34.1 (2019-07-20) [stable]

### Bugs Fixed
 

   - `luke` works with upgraded bootstrap luarocks version of `require`.

 

   - `posix.glob.glob` does not return a random errno on failure now,
but
     new module constants `GLOB_ABORTED`, `GLOB_NOMATCH` or
     `GLOB_NOSPACE`.
 

   - `posix.deprecated.clock_getres` and
`posix.deprecated.clock_gettime`
     work again.

 

### New Features
 

   - `posix.glob.glob` supports now module constants as a second
     argument: `GLOB_NOCHECK` and `GLOB_ERR`.

 

   - `posix.sys.socket` now supports IPV6 link-local addresses.

 

   - use `std.strict`, `std._debug` and `typecheck` modules when
     available, otherwise behave normally without those additional
     runtime checks.
 



Install it with LuaRocks, using:

     luarocks install luaposix 34.1