[ANN] luaposix 34.1.1 released

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[ANN] luaposix 34.1.1 released

Gary V. Vaughan
A library binding various POSIX APIs. POSIX is the IEEE Portable
Operating System Interface standard. luaposix is based on lposix.

I am happy to announce release 34.1.1 of luaposix.

If you have moved to the new low-level APIs, and don't rely on the Lua
backwards compatibility layer and convenience functions, you can safely
omit those dependencies and use the C layer only.

luaposix's home page is at https://github.com/luaposix/luaposix/, with
documentation at https://luaposix.github.io/luaposix.

## Noteworthy changes in release 34.1.1 (2019-07-27) [stable]

### Bugs Fixed

   - `posix.compat` really does work without `std.normalize` in the
`package.path` now.

 

Install it with LuaRocks, using:

     luarocks install luaposix 34.1.1