[ANN} LuaSec 0.7 released

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[ANN} LuaSec 0.7 released

Bruno Silvestre-2
LuaSec depends on OpenSSL, and integrates with LuaSocket to make it
easy to add secure connections to any Lua applications or scripts.

This version is compatible with Lua 5.1, 5.2, 5.3, and LuaJIT.

Main changes:
- Add support to OpenSSL 1.1.0
- Add support to elliptic curves list
- Add ssl.config that exports some OpenSSL information
- Add integration with luaossl

More information:
https://github.com/brunoos/luasec/wiki

Thanks to everyone that contributed to LuaSec.

regards
--
bruno

Reply | Threaded
Open this post in threaded view
|

Re: [ANN} LuaSec 0.7 released

Matthew Wild
On 2 July 2018 at 14:13, Bruno Silvestre <[hidden email]> wrote:
> LuaSec depends on OpenSSL, and integrates with LuaSocket to make it
> easy to add secure connections to any Lua applications or scripts.
>
> This version is compatible with Lua 5.1, 5.2, 5.3, and LuaJIT.

LuaSec is an essential dependency of Prosody, and it has progressed a
long way since we first started using it.

Thanks Bruno for your continued maintainership, and to everyone who
has contributed features and fixes to recent releases!

Regards,
Matthew